summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrepsac-by2023-08-08 07:50:44 +0300
committerrepsac-by2023-08-08 07:50:44 +0300
commit9ecb9b8f9eb6a6dc3b6050d0ac811f9aafc18a27 (patch)
treead51e67dbc79ca5af48f26404e790bad6d549324
parent9c7df3704b17b5cc8cd04ded09c7bbff6e27dc93 (diff)
downloadaur-9ecb9b8f9eb6a6dc3b6050d0ac811f9aafc18a27.tar.gz
add gcc13.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--gcc13.patch38
3 files changed, 46 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d4c162ee9ab..816e11a132ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = litecoin-git
pkgver = 0.21.2.2+0+g953811f77a
- pkgrel = 1
+ pkgrel = 2
url = http://www.litecoin.org/
arch = x86_64
license = MIT
@@ -19,11 +19,13 @@ pkgbase = litecoin-git
source = litecoind.service
source = litecoin.sysusers
source = boost1770.patch
+ source = gcc13.patch
sha256sums = SKIP
sha256sums = ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96
sha256sums = 98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88
sha256sums = a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db
sha256sums = 3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5
+ sha256sums = f1ea3a54aa3daa4b7bf96e916a1c6aab02faee8a58993add84608315a3753dba
pkgname = litecoin-daemon-git
pkgdesc = Litecoin is a peer-to-peer network based digital currency - daemon
diff --git a/PKGBUILD b/PKGBUILD
index fa74025823dd..88d3e65637a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=litecoin-git
pkgname=('litecoin-daemon-git' 'litecoin-cli-git' 'litecoin-qt-git' 'litecoin-tx-git')
git_branch=0.21
pkgver=0.21.2.2+0+g953811f77a
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="http://www.litecoin.org/"
license=('MIT')
@@ -27,12 +27,14 @@ source=(
'litecoind.service'
'litecoin.sysusers'
'boost1770.patch'
+ 'gcc13.patch'
)
sha256sums=('SKIP'
'ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96'
'98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88'
'a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db'
- '3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5')
+ '3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5'
+ 'f1ea3a54aa3daa4b7bf96e916a1c6aab02faee8a58993add84608315a3753dba')
prepare() {
@@ -40,6 +42,7 @@ prepare() {
autoreconf -fi
patch -Np1 -i ../boost1770.patch
+ patch -Np1 -i ../gcc13.patch
}
pkgver() {
diff --git a/gcc13.patch b/gcc13.patch
new file mode 100644
index 000000000000..d1be2ae3a5ab
--- /dev/null
+++ b/gcc13.patch
@@ -0,0 +1,38 @@
+diff --git a/src/support/lockedpool.cpp b/src/support/lockedpool.cpp
+index 26de780f2..9e6a68d42 100644
+--- a/src/support/lockedpool.cpp
++++ b/src/support/lockedpool.cpp
+@@ -21,6 +21,7 @@
+ #include <unistd.h> // for sysconf
+ #endif
+
++#include <stdexcept>
+ #include <algorithm>
+ #ifdef ARENA_DEBUG
+ #include <iomanip>
+diff --git a/src/util/bip32.h b/src/util/bip32.h
+index 347e83db9..6ef051c48 100644
+--- a/src/util/bip32.h
++++ b/src/util/bip32.h
+@@ -6,6 +6,7 @@
+ #define BITCOIN_UTIL_BIP32_H
+
+ #include <attributes.h>
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+diff --git a/src/util/string.h b/src/util/string.h
+index a0c87bd00..f73c1bb9f 100644
+--- a/src/util/string.h
++++ b/src/util/string.h
+@@ -9,7 +9,9 @@
+
+ #include <algorithm>
+ #include <array>
++#include <cstdint>
+ #include <cstring>
++#include <iterator>
+ #include <locale>
+ #include <sstream>
+ #include <string>