summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Jamison2018-08-13 10:26:10 -0500
committerCaleb Jamison2018-08-13 10:26:10 -0500
commit1dc939797b1496c73e580a5805f0767d4090f162 (patch)
tree9283fbc831e14ed3382e908c2c4abbb924bb4b1a
parent0b7c3be9eca10776961fe1f89dbe8c126176c21c (diff)
downloadaur-1dc939797b1496c73e580a5805f0767d4090f162.tar.gz
Removed unneeded patch, fixed typo in dep
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--removed_sections.patch20
3 files changed, 4 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd3f9bd1621c..e5e1ce0239b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,15 +8,13 @@ pkgbase = litex-git
depends = python
depends = migen
optdepends = lm32-elf-binutils: lm32 soft core
- optdepends = lm32-eld-gcc: lm32 soft core
+ optdepends = lm32-elf-gcc: lm32 soft core
optdepends = riscv64-unknown-elf-binutils: picorv32 and vexriscv soft cores
optdepends = riscv64-unknown-elf-gcc: picorv32 and vexriscv soft cores
provides = litex
options = !emptydirs
source = git+https://github.com/enjoy-digital/litex
- source = removed_sections.patch
sha256sums = SKIP
- sha256sums = 13509ea8953b0e696539e604979e5411dafeaceb8da46acc52d701095e4f5534
pkgname = litex-git
diff --git a/PKGBUILD b/PKGBUILD
index f5d88ee722f0..6d54d2edfa85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,14 @@ license=('MIT')
groups=()
depends=('python' 'migen')
optdepends=('lm32-elf-binutils: lm32 soft core'
- 'lm32-eld-gcc: lm32 soft core'
+ 'lm32-elf-gcc: lm32 soft core'
'riscv64-unknown-elf-binutils: picorv32 and vexriscv soft cores'
'riscv64-unknown-elf-gcc: picorv32 and vexriscv soft cores')
provides=('litex')
options=(!emptydirs)
install=
-source=("git+https://github.com/enjoy-digital/litex" "removed_sections.patch")
-sha256sums=('SKIP' '13509ea8953b0e696539e604979e5411dafeaceb8da46acc52d701095e4f5534')
+source=("git+https://github.com/enjoy-digital/litex")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%%-git}"
@@ -28,7 +28,6 @@ prepare() {
rm -rf test/__init__.py
git submodule init
git submodule update
- patch -Np1 -i "${srcdir}/removed_sections.patch"
}
build() {
diff --git a/removed_sections.patch b/removed_sections.patch
deleted file mode 100644
index 30c583e25393..000000000000
--- a/removed_sections.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/litex/soc/software/bios/linker.ld b/litex/soc/software/bios/linker.ld
-index 13b4bcae..b57dc8b2 100644
---- a/litex/soc/software/bios/linker.ld
-+++ b/litex/soc/software/bios/linker.ld
-@@ -18,6 +18,7 @@ SECTIONS
- _frodata = .;
- *(.rodata .rodata.* .gnu.linkonce.r.*)
- *(.rodata1)
-+ *(.sdata .sdata.* .gnu.linkonce.s.*)
-
- /* Make sure the file is aligned on disk as well
- as in memory; CRC calculation requires that. */
-@@ -47,7 +48,6 @@ SECTIONS
- *(.comment)
- *(.data .data.* .gnu.linkonce.d.*)
- *(.data1)
-- *(.sdata .sdata.* .gnu.linkonce.s.*)
- }
- }
-