summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Jamison2018-06-10 07:01:28 -0500
committerCaleb Jamison2018-06-10 07:01:28 -0500
commit8efa7a993bb1f024dd0385b718640698941d4980 (patch)
tree604561622f5aa5710dbc418c2e9ed0586b3d3d54
downloadaur-8efa7a993bb1f024dd0385b718640698941d4980.tar.gz
PKGBUILD and .SRCINFO for Litex-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
-rw-r--r--removed_sections.patch20
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67ea3c9cefc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = litex-git
+ pkgdesc = Migen based SoC
+ pkgver = 3724
+ pkgrel = 1
+ url = https://github.com/enjoy-digital/litex
+ arch = any
+ license = MIT
+ depends = python
+ depends = migen
+ optdepends = lm32-elf-binutils: lm32 soft core
+ optdepends = lm32-eld-gcc: lm32 soft core
+ optdepends = riscv64-unknown-elf-binutils: picorv32 and vexriscv soft cores
+ optdepends = riscv64-unknown-elf-gcc: picorv32 and vexriscv soft cores
+ options = !emptydirs
+ source = git+https://github.com/enjoy-digital/litex
+ source = removed_sections.patch
+ sha256sums = SKIP
+ sha256sums = 13509ea8953b0e696539e604979e5411dafeaceb8da46acc52d701095e4f5534
+
+pkgname = litex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1766ef54059e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Caleb Jamison <cbjamo@gmail.com>
+pkgname=litex-git
+pkgver=3724
+pkgrel=1
+pkgdesc="Migen based SoC"
+arch=(any)
+url="https://github.com/enjoy-digital/litex"
+license=('MIT')
+groups=()
+depends=('python' 'migen')
+optdepends=('lm32-elf-binutils: lm32 soft core'
+ 'lm32-eld-gcc: lm32 soft core'
+ 'riscv64-unknown-elf-binutils: picorv32 and vexriscv soft cores'
+ 'riscv64-unknown-elf-gcc: picorv32 and vexriscv soft cores')
+provides=()
+options=(!emptydirs)
+install=
+source=("git+https://github.com/enjoy-digital/litex" "removed_sections.patch")
+sha256sums=('SKIP' '13509ea8953b0e696539e604979e5411dafeaceb8da46acc52d701095e4f5534')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%%-git}"
+ git rev-list --count HEAD
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%%-git}"
+ rm -rf test/__init__.py
+ git submodule init
+ git submodule update
+ patch -Np1 -i "${srcdir}/removed_sections.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname%%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname%%-git}"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
+}
+
diff --git a/removed_sections.patch b/removed_sections.patch
new file mode 100644
index 000000000000..30c583e25393
--- /dev/null
+++ b/removed_sections.patch
@@ -0,0 +1,20 @@
+diff --git a/litex/soc/software/bios/linker.ld b/litex/soc/software/bios/linker.ld
+index 13b4bcae..b57dc8b2 100644
+--- a/litex/soc/software/bios/linker.ld
++++ b/litex/soc/software/bios/linker.ld
+@@ -18,6 +18,7 @@ SECTIONS
+ _frodata = .;
+ *(.rodata .rodata.* .gnu.linkonce.r.*)
+ *(.rodata1)
++ *(.sdata .sdata.* .gnu.linkonce.s.*)
+
+ /* Make sure the file is aligned on disk as well
+ as in memory; CRC calculation requires that. */
+@@ -47,7 +48,6 @@ SECTIONS
+ *(.comment)
+ *(.data .data.* .gnu.linkonce.d.*)
+ *(.data1)
+- *(.sdata .sdata.* .gnu.linkonce.s.*)
+ }
+ }
+