summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDusan Baran2017-11-21 14:12:05 +0000
committerDusan Baran2017-11-21 14:12:05 +0000
commitaa3ff24e816683ae1e4bdcd3c4edc91618a16a86 (patch)
tree865bb616164db13930ac894819b204c2ae88ae8a
downloadaur-aa3ff24e816683ae1e4bdcd3c4edc91618a16a86.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..feee5371cbdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = litify-git
+ pkgdesc = LITify git
+ pkgver = 96590e0
+ pkgrel = 1
+ url = https://github.com/dudoslav/litify
+ arch = any
+ license = GPL3
+ depends = git
+ depends = pacman
+ optdepends = noto-fonts-emoji
+ optdepends = unicode-emoji
+ source = git+https://github.com/dudoslav/litify.git
+ sha256sums = SKIP
+
+pkgname = litify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12ad0816a706
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dusan Baran <work.dusanbaran@gmail.com>
+
+_pkgname=litify
+pkgname=litify-git
+pkgver=96590e0
+pkgrel=1
+pkgdesc="LITify git"
+arch=('any')
+url="https://github.com/dudoslav/${_pkgname}"
+license=('GPL3')
+depends=('git'
+ 'pacman')
+optdepends=('noto-fonts-emoji'
+ 'unicode-emoji')
+source=("git+https://github.com/dudoslav/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -m 755 -D "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -m 644 -D 'lit' "$pkgdir/etc/lit"
+}
+