summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-17 17:44:24 -0500
committerLuis Martinez2022-07-17 17:44:24 -0500
commit6357c6a8e023dc77fd929e719ff6375999c0f25c (patch)
tree08a5b2bedd1ffd12d8d30cdc4959c80d653421ca
parent02f5b479cb928bd8fb50a9d8a8aa2b2f0e49e1f4 (diff)
downloadaur-6357c6a8e023dc77fd929e719ff6375999c0f25c.tar.gz
package cleanup
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD44
2 files changed, 42 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61a2b00a4306..8236c9efda21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = litmusctl
- pkgdesc = The Litmuschaos command-line tool, litmusctl, allows you to manage litmuschaos agent plane. You can use litmusctl to create agents, project, and manage multiple litmuschaos accounts.
+ pkgdesc = CLI tool to manage litmuschaos's agent plane
pkgver = 0.11.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/litmuschaos/litmusctl
arch = x86_64
- license = APACHE
+ arch = aarch64
+ license = Apache
+ makedepends = go
depends = kubectl
- source = https://github.com/litmuschaos/litmusctl/releases/download/v0.11.0/litmusctl-linux-amd64-v0.11.0.tar.gz
- sha256sums = 8954af06a04e2d78d13121ac1f894013aa73a5e964f97c5fa6df5c8b98c5591b
+ source = litmusctl-0.11.0.tar.gz::https://github.com/litmuschaos/litmusctl/archive/v0.11.0.tar.gz
+ sha256sums = 2fa189d2869f3046e98048dd824ac7a76a635f5f10432e2e6ed5448e4e4c3f57
pkgname = litmusctl
diff --git a/PKGBUILD b/PKGBUILD
index 4af8872fe68f..db7fa8d0982e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,40 @@
-# Maintainer: Ray Del Rosario <michael@raydelrosario.com>
-pkgname='litmusctl'
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Ray Del Rosario <michael@raydelrosario.com>
+
+pkgname=litmusctl
pkgver=0.11.0
-pkgrel=1
-pkgdesc='The Litmuschaos command-line tool, litmusctl, allows you to manage litmuschaos agent plane. You can use litmusctl to create agents, project, and manage multiple litmuschaos accounts.'
+pkgrel=2
+pkgdesc="CLI tool to manage litmuschaos's agent plane"
url='https://github.com/litmuschaos/litmusctl'
-arch=('x86_64')
-license=('APACHE')
+arch=('x86_64' 'aarch64')
+license=('Apache')
depends=('kubectl')
-source=("https://github.com/litmuschaos/litmusctl/releases/download/v${pkgver}/litmusctl-linux-amd64-v${pkgver}.tar.gz")
-sha256sums=('8954af06a04e2d78d13121ac1f894013aa73a5e964f97c5fa6df5c8b98c5591b')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('2fa189d2869f3046e98048dd824ac7a76a635f5f10432e2e6ed5448e4e4c3f57')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ go mod download
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ cd "$pkgname-$pkgver"
+ go build -o build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
package() {
- install -Dm755 "$srcdir/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cd "$pkgname-$pkgver"
+ install -D "build/$pkgname" -t "$pkgdir/usr/bin/"
}