summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Del Rosario2021-08-17 21:59:50 -0500
committerMichael Del Rosario2021-08-17 21:59:50 -0500
commit8f1c79e95fe54fd4fa1ec072341630bc3fc0fc6b (patch)
tree0155852211e5a64d8886196f1dd79be8e57f1fc0
downloadaur-8f1c79e95fe54fd4fa1ec072341630bc3fc0fc6b.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 27 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebf80872c04d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = litmusctl
+ pkgdesc = The Litmuschaos command-line tool, litmusctl, allows you to manage litmuschaos agent plane. You can use litmusctl to create agents, project, and manage multiple litmuschaos accounts.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/litmuschaos/litmusctl
+ arch = amd64
+ license = APACHE
+ depends = kubectl
+ source = https://litmusctl-bucket.s3-eu-west-1.amazonaws.com/litmusctl-linux-amd64-v0.3.0.tar.gz
+ md5sums = SKIP
+
+pkgname = litmusctl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e8310385c56d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..030d77042307
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: Michael Del Rosario <m@delrosariomichael.com>
+pkgname='litmusctl'
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='The Litmuschaos command-line tool, litmusctl, allows you to manage litmuschaos agent plane. You can use litmusctl to create agents, project, and manage multiple litmuschaos accounts.'
+url='https://github.com/litmuschaos/litmusctl'
+arch=('amd64')
+license=('APACHE')
+depends=('kubectl')
+source=("https://litmusctl-bucket.s3-eu-west-1.amazonaws.com/litmusctl-linux-${arch}-v${pkgver}.tar.gz")
+md5sums=('SKIP')
+package() {
+ install -Dm755 "$srcdir/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+} \ No newline at end of file