summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-21 08:00:54 +0300
committerDimitris Kiziridis2020-05-21 08:00:54 +0300
commit1528d06ed58b167e864677f264e34448c8e35173 (patch)
tree7a1bd04065360bdce5b6dd481480be7a46fa5b87
downloadaur-1528d06ed58b167e864677f264e34448c8e35173.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD51
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ae1b5ac104a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = little-brother
+ pkgdesc = Parental Control Application implemented in Python 3 to monitor and limit kids' play time on Linux hosts
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/marcus67/little_brother
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-alembic
+ depends = python-requests
+ depends = python-psutil
+ depends = python-dateutil
+ depends = python-sqlalchemy
+ depends = python-pymysql
+ depends = python-markupsafe
+ depends = python-flask-babel
+ depends = python-flask-login
+ depends = python-flask-migrate
+ depends = python-flask-wtf
+ depends = python-flask_helpers
+ depends = python-selenium
+ depends = python-urllib3
+ depends = python-prometheus_client
+ depends = python-psycopg2
+ depends = postgresql
+ depends = zenity
+ source = little-brother-0.2.1.tar.gz::https://github.com/marcus67/little_brother/archive/0.2.1.tar.gz
+ sha256sums = 277e3d33fac94a6319f7b11d9647dddfb5914146c7a567326234c5c427bb40e2
+
+pkgname = little-brother
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fc556457dc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=little-brother
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Parental Control Application implemented in Python 3 to monitor and limit kids' play time on Linux hosts"
+arch=('any')
+url='https://github.com/marcus67/little_brother'
+license=('GPL3')
+depends=('python-alembic'
+ 'python-requests'
+ 'python-psutil'
+ 'python-dateutil'
+ 'python-sqlalchemy'
+ 'python-pymysql'
+ 'python-markupsafe'
+ 'python-flask-babel'
+ 'python-flask-login'
+ 'python-flask-migrate'
+ 'python-flask-wtf'
+ 'python-flask_helpers'
+ 'python-selenium'
+ 'python-urllib3'
+ 'python-prometheus_client'
+ 'python-psycopg2'
+ 'postgresql'
+ 'zenity')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/marcus67/little_brother/archive/${pkgver}.tar.gz")
+sha256sums=('277e3d33fac94a6319f7b11d9647dddfb5914146c7a567326234c5c427bb40e2')
+
+prepare() {
+ cd "little_brother-${pkgver}"
+ sed -i "s/==/>=/" requirements.txt
+ sed -i 's|/local||' etc/little-brother.service
+}
+
+build() {
+ cd "little_brother-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "little_brother-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 etc/little-brother.service -t "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm644 etc/little-brother.sudo "${pkgdir}/etc/sudoers.d/little-brother"
+ install -Dm644 etc/*.config -t "${pkgdir}/etc/little-brother"
+ install -d "${pkgdir}/usr/share/doc/little-brother"
+ cp -aR doc/* "${pkgdir}/usr/share/doc/little-brother"
+} \ No newline at end of file