summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-28 16:41:52 -0500
committerLuis Martinez2022-03-28 16:41:52 -0500
commita8b86fab673de33f63fee5ecd5d7bbcf7d6772fd (patch)
treef2e4be63062f2ffe2b27330c7457ffbc96984627
parentaa638aa54c6ea2457fba19243435ade48da08569 (diff)
downloadaur-a8b86fab673de33f63fee5ecd5d7bbcf7d6772fd.tar.gz
fix file structure
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--little-brother.tmpfiles4
3 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b27569bd8bf..766dbe20fe14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = little-brother
pkgdesc = Parental controls for children
pkgver = 0.4.19
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/marcus67/little_brother
changelog = CHANGES.md
arch = any
@@ -31,9 +31,12 @@ pkgbase = little-brother
depends = python-some-flask-helpers
depends = python-ldap
depends = python-distro
+ backup = etc/little-brother/little-brother.conf
source = little-brother-0.4.19.tar.gz::https://github.com/marcus67/little_brother/archive/0.4.19.tar.gz
source = little-brother.sysusers
+ source = little-brother.tmpfiles
sha256sums = dbfe9fefe4a9fb9c179042672239f214d1235b4bf2f318fcb66954e493d5713e
sha256sums = 2d4477508d5562bf47cf382f1530175808a3034329daa11a62a5276a709d9b35
+ sha256sums = c427a5bbea15bb42d0738ee17437d5f01e0ba9e120bed812a95c29edb4827af7
pkgname = little-brother
diff --git a/PKGBUILD b/PKGBUILD
index 10b8796d35b5..d630014aab5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=little-brother
pkgver=0.4.19
-pkgrel=3
+pkgrel=4
pkgdesc="Parental controls for children"
arch=('any')
url='https://github.com/marcus67/little_brother'
@@ -31,11 +31,14 @@ depends=(
'python-ldap'
'python-distro')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+backup=("etc/$pkgname/$pkgname.conf")
changelog=CHANGES.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
- "$pkgname.sysusers")
+ "$pkgname.sysusers"
+ "$pkgname.tmpfiles")
sha256sums=('dbfe9fefe4a9fb9c179042672239f214d1235b4bf2f318fcb66954e493d5713e'
- '2d4477508d5562bf47cf382f1530175808a3034329daa11a62a5276a709d9b35')
+ '2d4477508d5562bf47cf382f1530175808a3034329daa11a62a5276a709d9b35'
+ 'c427a5bbea15bb42d0738ee17437d5f01e0ba9e120bed812a95c29edb4827af7')
prepare() {
cd "little_brother-$pkgver"
@@ -54,7 +57,8 @@ package() {
python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 "etc/$pkgname.service" -t "$pkgdir/usr/lib/systemd/system/"
install -Dm644 "etc/$pkgname.sudo" "$pkgdir/etc/sudoers.d/$pkgname"
- install -Dm644 "etc/$pkgname.tmpfile" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
- install -Dm644 etc/*.config -t "$pkgdir/etc/$pkgname/"
+ install -Dm644 etc/master.config "$pkgdir/etc/$pkgname/$pkgname.config"
+ install -Dm644 etc/*.config -t "$pkgdir/usr/share/$pkgname/"
install -Dm644 "$srcdir/$pkgname.sysusers" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -Dm644 "$srcdir/$pkgname.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
}
diff --git a/little-brother.tmpfiles b/little-brother.tmpfiles
new file mode 100644
index 000000000000..5909aff924d8
--- /dev/null
+++ b/little-brother.tmpfiles
@@ -0,0 +1,4 @@
+d /var/lib/little-brother - little-brother little-brother
+d /var/log/little-brother - little-brother little-brother
+d /var/spool/little-brother - little-brother little-brother
+d /run/little-brother - little-brother little-brother