summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-28 21:26:32 -0600
committerLuis Martinez2022-02-28 21:26:32 -0600
commitffa49887c35e9a08e22f59788dd61cd97a43a573 (patch)
tree19981bbcb2cfff6f147030c46a747dab467ce8ec
parent27adf51046c42c7b69805f105456ab1d98e041f0 (diff)
downloadaur-ffa49887c35e9a08e22f59788dd61cd97a43a573.tar.gz
update to 0.4.19
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGES.md46
-rw-r--r--PKGBUILD11
3 files changed, 53 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2c8c35b6a93..274eba0e95cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = little-brother
pkgdesc = Parental controls for children
- pkgver = 0.4.12
+ pkgver = 0.4.19
pkgrel = 1
url = https://github.com/marcus67/little_brother
changelog = CHANGES.md
arch = any
license = GPL3
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-alembic
depends = python-lagom
depends = python-requests
@@ -24,9 +27,9 @@ pkgbase = little-brother
depends = python-urllib3
depends = python-prometheus_client
depends = python-humanize
- source = little-brother-0.4.12.tar.gz::https://github.com/marcus67/little_brother/archive/0.4.12.tar.gz
+ source = little-brother-0.4.19.tar.gz::https://github.com/marcus67/little_brother/archive/0.4.19.tar.gz
source = little-brother.sysusers
- sha256sums = 2fe8d3fe846193d2917c52d85e8f3c3a782357654d796fcb9957be4328fda0ee
+ sha256sums = dbfe9fefe4a9fb9c179042672239f214d1235b4bf2f318fcb66954e493d5713e
sha256sums = 2d4477508d5562bf47cf382f1530175808a3034329daa11a62a5276a709d9b35
pkgname = little-brother
diff --git a/CHANGES.md b/CHANGES.md
index 4b19842823e0..f7e0d8aad16e 100644
--- a/CHANGES.md
+++ b/CHANGES.md
@@ -4,6 +4,44 @@
This document lists all changes of `LittleBrother` with the most recent changes at the top.
+## Version 0.4.19 Revision 121 (February 13th, 2022)
+
+* Upgrade to `python_base_app` version 0.2.36 (lots of trouble releasing `python_base_app`)
+
+## Version 0.4.18 Revision 119 (February 5th, 2022)
+
+* Upgrade to `python_base_app` version 0.2.34
+
+## Version 0.4.17 Revision 117 (January 30th, 2022)
+
+* Closes #166, see [here](https://github.com/marcus67/little_brother/issues/166)
+ (Thanks to [Bas Hulsken](https://github.com/bhulsken)!)
+* Upgrade package `alembic` to version 1.7.5
+* Make upgrade message in administration views more concise, include link to `CHANGES.md`
+
+## Version 0.4.16 Revision 116 (January 30th, 2022)
+
+* Upgrade to `python_base_app` version 0.2.33
+* Closes #165, see [here](https://github.com/marcus67/little_brother/issues/165)
+
+## Version 0.4.15 Revision 115 (January 28th, 2022)
+
+* Upgrade to `python_base_app` version 0.2.31
+* Closes #158, see [here](https://github.com/marcus67/little_brother/issues/158)
+* Closes #164, see [here](https://github.com/marcus67/little_brother/issues/164)
+
+## Version 0.4.14 Revision 114 (January 6th, 2022)
+
+* Closes #163, see [here](https://github.com/marcus67/little_brother/issues/163)
+
+## Version 0.4.13 Revision 113 (January 5th, 2022)
+
+* Add CODE_OF_CONDUCT.md and CONTRIBUTING.md
+* Added Snyk package health score badge
+* Add second Docker image
+ [`little-brother-ubuntu-client`](https://hub.docker.com/repository/docker/marcusrickert/little-brother-ubuntu-client)
+* Renamed Docker image `little-brother-slave` to `little-brother-client`.
+
## Version 0.4.12 Revision 112 (December 29th, 2021)
* Closes #87, see [here](https://github.com/marcus67/little_brother/issues/87)
@@ -39,7 +77,7 @@ This document lists all changes of `LittleBrother` with the most recent changes
* Upgrade WTForms to version 3.0.0a1
-## Version 0.4.8 Revision 107 (August 21th, 2021)
+## Version 0.4.8 Revision 107 (August 21st, 2021)
* Closes #130, see [here](https://github.com/marcus67/little_brother/issues/130)
* Provide `ruleset_check_interval` in `UserStatus`
@@ -96,9 +134,9 @@ This document lists all changes of `LittleBrother` with the most recent changes
* Split up test class `TestStatusServer`
* Add test cases for users page:
* add and delete user, edit user,
- * assign/unassign rule set,
+ * assign/un-assign rule set,
* move up/down rule set,
- * assign/unassign device
+ * assign/un-assign device
* Add test cases for devices page: add and delete device, edit device
* Add test cases for admin page: edit rule override, add, extend, and delete time extension
* Add test cases for invalid data in rule override and device
@@ -265,7 +303,7 @@ This document lists all changes of `LittleBrother` with the most recent changes
* Update Italian localization (locale "it")
* Issue error when no database user is given when driver != sqlite
* Register logging filter for alembic
-* Add latest change date of translations as column to localization table
+* Add the latest change date of translations as column to localization table
## Version 0.3.0 Revision 65 (July 18th, 2020)
diff --git a/PKGBUILD b/PKGBUILD
index 3a4258443395..4c31ceb4be6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=little-brother
-pkgver=0.4.12
+pkgver=0.4.19
pkgrel=1
pkgdesc="Parental controls for children"
arch=('any')
@@ -26,29 +26,28 @@ depends=(
'python-urllib3'
'python-prometheus_client'
'python-humanize')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
changelog=CHANGES.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"$pkgname.sysusers")
-sha256sums=('2fe8d3fe846193d2917c52d85e8f3c3a782357654d796fcb9957be4328fda0ee'
+sha256sums=('dbfe9fefe4a9fb9c179042672239f214d1235b4bf2f318fcb66954e493d5713e'
'2d4477508d5562bf47cf382f1530175808a3034329daa11a62a5276a709d9b35')
prepare() {
cd "little_brother-$pkgver"
- sed -i "s/==/>=/g" requirements.txt
sed -i 's|/local||g' "etc/$pkgname.service"
sed -i '/little_brother.test*/d' setup.py
}
build() {
cd "little_brother-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
export PYTHONHASHSEED=0
cd "little_brother-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 "etc/$pkgname.service" -t "$pkgdir/usr/lib/systemd/system/"
install -Dm644 "etc/$pkgname.sudo" "$pkgdir/etc/sudoers.d/$pkgname"
install -Dm644 "etc/$pkgname.tmpfile" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"