summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-05-23 19:40:46 +0000
committerDaniel Bermond2020-05-23 19:40:46 +0000
commit587462e7645cf79d17c13df315975dc9ff8c5636 (patch)
tree21cc7952de53e2e93a8ea90ed20a450492664883
parentadeaf202bb77c0de322f417f459726a4ff441416 (diff)
downloadaur-587462e7645cf79d17c13df315975dc9ff8c5636.tar.gz
Updated to version 1.2.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5812fca0c85..a5bd063e172f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = littleutils-full
pkgdesc = Utilities for compression, file manipulation, text cleanup, and images/PDF optimization (with all features and extras)
- pkgver = 1.0.43
+ pkgver = 1.2.0
pkgrel = 1
url = http://littleutils.sourceforge.net/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = littleutils-full
depends = bash
depends = dash
depends = perl
- depends = python3
+ depends = python
depends = gifsicle
depends = ghostscript
depends = img2pdf
@@ -23,12 +23,13 @@ pkgbase = littleutils-full
depends = xz
depends = p7zip
depends = wget
+ depends = zstd
depends = lzma_alone
provides = littleutils
conflicts = littleutils
conflicts = file-rename-utils
- source = https://sourceforge.net/projects/littleutils/files/littleutils-source/1.0.43/littleutils-1.0.43.tar.xz
- sha256sums = f6acca3310ac22ef747956d955ca7c3af5707bcb70a4d1df8d159399c2161c14
+ source = https://sourceforge.net/projects/littleutils/files/littleutils-source/1.2.0/littleutils-1.2.0.tar.xz
+ sha256sums = 0c301799445ec906fd56762051044c10642e91e7043d80ebe3758a82b0fea945
pkgname = littleutils-full
diff --git a/PKGBUILD b/PKGBUILD
index b51eea23c5b3..dfc87573d78b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=littleutils-full
-pkgver=1.0.43
+pkgver=1.2.0
pkgrel=1
pkgdesc='Utilities for compression, file manipulation, text cleanup, and images/PDF optimization (with all features and extras)'
arch=('x86_64')
@@ -9,18 +9,19 @@ url='http://littleutils.sourceforge.net/'
license=('custom')
depends=(
# official repositories:
- 'bash' 'dash' 'perl' 'python3' 'gifsicle' 'ghostscript' 'img2pdf' 'imlib2'
+ 'bash' 'dash' 'perl' 'python' 'gifsicle' 'ghostscript' 'img2pdf' 'imlib2'
'libjpeg-turbo' 'libpng' 'pngcrush' 'bzip2' 'gzip' 'lzip' 'lzop' 'xz'
- 'p7zip' 'wget'
+ 'p7zip' 'wget' 'zstd'
# AUR:
'lzma_alone'
)
provides=('littleutils')
conflicts=('littleutils' 'file-rename-utils')
source=("https://sourceforge.net/projects/littleutils/files/littleutils-source/${pkgver}/littleutils-${pkgver}.tar.xz")
-sha256sums=('f6acca3310ac22ef747956d955ca7c3af5707bcb70a4d1df8d159399c2161c14')
+sha256sums=('0c301799445ec906fd56762051044c10642e91e7043d80ebe3758a82b0fea945')
build() {
+ export CFLAGS+=" ${CPPFLAGS}"
cd "littleutils-${pkgver}"
./configure --prefix='/usr'
make