summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-06-16 17:17:45 +0000
committerDaniel Bermond2018-06-16 17:17:45 +0000
commitd743e0a22e2b92e11565edc54d59d86b221df7d9 (patch)
treee0f58653bb2960e1f9d05de9ed42a06c2c21068f
parenta17fb94bcff6301160084f2179a0e6124763316f (diff)
downloadaur-d743e0a22e2b92e11565edc54d59d86b221df7d9.tar.gz
Add missing ghostscript dependency. Cosmetic changes.
-rw-r--r--.SRCINFO8
-rw-r--r--[-rwxr-xr-x]PKGBUILD38
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 712a57033b00..1945106a8a71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
-# Generated by mksrcinfo v8
-# Sat Jan 21 23:26:29 UTC 2017
pkgbase = littleutils-full
pkgdesc = Utilities for compression, file manipulation, text cleanup, and images/PDF optimization (with all features and extras)
pkgver = 1.0.37
- pkgrel = 1
+ pkgrel = 2
url = http://littleutils.sourceforge.net/
arch = i686
arch = x86_64
license = custom
- license = GPL3
depends = bash
depends = dash
depends = perl
@@ -21,11 +18,12 @@ pkgbase = littleutils-full
depends = bzip2
depends = gzip
depends = lzip
- depends = lzma_alone
depends = lzop
depends = xz
depends = p7zip
+ depends = ghostscript
depends = wget
+ depends = lzma_alone
provides = littleutils
conflicts = littleutils
source = https://sourceforge.net/projects/littleutils/files/littleutils-source/1.0.37/littleutils-1.0.37.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 35dbd3c0ff29..a57f64fc85bd 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,17 @@
_srcname=littleutils
pkgname=littleutils-full
pkgver=1.0.37
-pkgrel=1
-pkgdesc="Utilities for compression, file manipulation, text cleanup, and images/PDF optimization (with all features and extras)"
+pkgrel=2
+pkgdesc='Utilities for compression, file manipulation, text cleanup, and images/PDF optimization (with all features and extras)'
arch=('i686' 'x86_64')
-url="http://littleutils.sourceforge.net/"
-license=('custom' 'GPL3')
-depends=('bash' 'dash' 'perl' 'python2' 'file' 'gifsicle' 'libjpeg-turbo' 'libpng'
- 'pngcrush' 'bzip2' 'gzip' 'lzip' 'lzma_alone' 'lzop' 'xz' 'p7zip' 'wget'
+url='http://littleutils.sourceforge.net/'
+license=('custom')
+depends=(
+ # official repositories:
+ 'bash' 'dash' 'perl' 'python2' 'file' 'gifsicle' 'libjpeg-turbo' 'libpng'
+ 'pngcrush' 'bzip2' 'gzip' 'lzip' 'lzop' 'xz' 'p7zip' 'ghostscript' 'wget'
+ # AUR:
+ 'lzma_alone'
)
provides=('littleutils')
conflicts=('littleutils')
@@ -17,18 +21,18 @@ source=("https://sourceforge.net/projects/littleutils/files/littleutils-source/$
sha256sums=('f846ab6d2793499c99472469a2a74d9e57ee336320700bd540e2bc6ab0ec76da')
build() {
- cd "$_srcname"-"$pkgver"
-
- ./configure --prefix=/usr
-
- make
+ cd "${_srcname}-${pkgver}"
+
+ ./configure --prefix='/usr'
+
+ make
}
package() {
- cd "$_srcname"-"$pkgver"
-
- make DESTDIR="$pkgdir/" install
- make DESTDIR="$pkgdir/" install-extra
-
- install -D -m644 LICENSES "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES"
+ cd "${_srcname}-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-extra
+
+ install -D -m644 LICENSES "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES"
}