summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Abernethy2016-02-17 19:11:50 +0100
committerPhilip Abernethy2016-02-17 19:11:50 +0100
commit4eeeaf65b674c03a0d11a80e36d386578b80e25b (patch)
tree03c552fe6a5de291c2345135d87b34078ef7fdd2
downloadaur-4eeeaf65b674c03a0d11a80e36d386578b80e25b.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85590f7c0427
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Feb 17 18:06:50 UTC 2016
+pkgbase = litwr
+ pkgdesc = Life in the Woods Renaissance is a modpack for Minecraft.
+ pkgver = 20160213
+ pkgrel = 1
+ url = http://lifeinthewoods.ca
+ arch = any
+ license = GPLv3
+ depends = java-runtime>=7
+ source = http://lifeinthewoods.getitfromhere.co.uk/downloads/LifeInTheWoodsRenaissanceLauncher.zip
+ sha512sums = 7a3e450bfacfefa65290a9d683989f1362edfb0d1d45cbae8bd4bceb271e72a6f27ad3b3e124dc8092e58c8732edead236a0ccc67927840e7466cc3253bdfa8b
+
+pkgname = litwr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebd4d46b7f79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Philip Abernethy<chais.z3r0@gmail.com>
+pkgname=litwr
+pkgver=20160213
+pkgrel=1
+pkgdesc="Life in the Woods Renaissance is a modpack for Minecraft."
+url="http://lifeinthewoods.ca"
+arch=('any')
+license=('GPLv3')
+depends=('java-runtime>=7')
+
+source=("http://lifeinthewoods.getitfromhere.co.uk/downloads/LifeInTheWoodsRenaissanceLauncher.zip")
+sha512sums=('7a3e450bfacfefa65290a9d683989f1362edfb0d1d45cbae8bd4bceb271e72a6f27ad3b3e124dc8092e58c8732edead236a0ccc67927840e7466cc3253bdfa8b')
+
+package() {
+ install -d "${pkgdir}"/{opt/litwr,usr/share/{applications,licenses}}
+ install -m644 "${srcdir}"/litwrl.jar "${pkgdir}"/opt/litwr/litwrl.jar
+ install -m644 "${srcdir}"/utils/appicon.png "${pkgdir}"/opt/litwr/appicon.png
+ cat > "${pkgdir}"/usr/share/applications/litwr.desktop <<EOF
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name="Life in the Woods Renaissance"
+Comment="Starts the launcher of Life in the Woods Renaissance"
+Exec=/usr/bin/java -jar /opt/litwr/litwrl.jar
+Icon=/opt/litwr/appicon.png
+Path=/opt/litwr
+Terminal=false
+StartupNotify=false
+EOF
+}