summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjooch2015-07-07 12:47:35 +0200
committerjooch2015-07-07 12:47:35 +0200
commit22b8627e18d76eff848c0eb8342b88b69c0af1d2 (patch)
treeb2d9a4c56c263afdd86a16e9153b198aaa8d28d8
downloadaur-22b8627e18d76eff848c0eb8342b88b69c0af1d2.tar.gz
initial version
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD54
-rw-r--r--live-usb-install.desktop12
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9e0657ae825
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = live-usb-install
+ pkgdesc = LiveUSB Install - Create bootable usb sticks from a wide range of different Linux distributions
+ pkgver = 2.5.9
+ pkgrel = 1
+ url = http://live.learnfree.eu
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = pygtk
+ depends = libglade
+ depends = syslinux
+ depends = wget
+ depends = p7zip
+ depends = mtools
+ depends = unrar
+ depends = parted
+ depends = gksu
+ depends = python2-dbus
+ optdepends = python-libtorrent: needed for downloading some distributions
+ conflicts = live-usb-install<2.5.9
+ source = http://skss.learnfree.eu/go.php?http://download.learnfree.eu/lfu-usb/live-usb-install-2.5.9.tar.gz
+ source = live-usb-install.desktop
+ md5sums = e195f70162707c930d77a61a5ccc137d
+ md5sums = 3c0c278b60d2f6fe8887a94198b1796f
+
+pkgname = live-usb-install
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfac1d2a26bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Submitter: andre.laszlo
+# Maintainer: jooch
+# Contributors: Florian Dejonckheere <florian@floriandejonckheere.be>, Jooch <jooch (at) gmx (dot) com>
+
+pkgname=live-usb-install
+pkgver=2.5.9
+pkgrel=1
+pkgdesc="LiveUSB Install - Create bootable usb sticks from a wide range of different Linux distributions"
+url="http://live.learnfree.eu"
+license=('GPL')
+arch=('i686' 'x86_64')
+source=('http://skss.learnfree.eu/go.php?http://download.learnfree.eu/lfu-usb/live-usb-install-2.5.9.tar.gz'
+ 'live-usb-install.desktop')
+md5sums=('e195f70162707c930d77a61a5ccc137d'
+'3c0c278b60d2f6fe8887a94198b1796f')
+depends=('python2'
+ 'pygtk'
+ 'libglade'
+ 'syslinux'
+ 'wget'
+ 'p7zip'
+ 'mtools'
+ 'unrar'
+ 'parted'
+ 'gksu'
+ 'python2-dbus')
+optdepends=('python-libtorrent: needed for downloading some distributions')
+conflicts=('live-usb-install<2.5.9')
+
+package(){
+ cd ${srcdir}/${pkgname}
+
+ # Python2 hack
+ sed -i 's!#\!/usr/bin/env python!#\!/usr/bin/env python2!g' live-usb-install.py
+
+ mkdir -p ${pkgdir}/usr/share/{${pkgname},pixmaps,applications}
+
+ install -Dm644 appversion.py\
+ asubprocess.py\
+ live-usb-install.py\
+ live-usb-install.glade\
+ logo.png\
+ ${pkgdir}/usr/share/${pkgname}
+ cp -r presets\
+ pyudev\
+ locale\
+ syslinux\
+ templates\
+ wingrub\
+ ${pkgdir}/usr/share/${pkgname}
+ install -Dm644 logo.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+
+ install -Dm644 ${srcdir}/live-usb-install.desktop ${pkgdir}/usr/share/applications/
+} \ No newline at end of file
diff --git a/live-usb-install.desktop b/live-usb-install.desktop
new file mode 100644
index 000000000000..50a03dc8f292
--- /dev/null
+++ b/live-usb-install.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Name=LiveUSB Install
+Comment=Tool for creating Live USB drives
+Categories=Application;System;
+Exec=gksu python2 /usr/share/live-usb-install/live-usb-install.py
+Terminal=false
+Type=Application
+Name[en_US]=LiveUSB Install
+GenericName[en_US]=LiveUSB Install
+Comment[en_US]=Tool for creating Live USB drives
+Icon=live-usb-install