summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNelson Estevão2023-04-24 09:59:54 +0100
committerNelson Estevão2023-04-24 09:59:54 +0100
commita7c6c44b811603b36a2161e32980dc967765a9d3 (patch)
treeea179514dccb22ce04ddacc083cacfd9843765e4
parente5c808b3ab2c88e96b24d81513d6d8c41f94e30b (diff)
downloadaur-a7c6c44b811603b36a2161e32980dc967765a9d3.tar.gz
Update dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5e294d684d5..b7fab119915e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = livebook
- pkgdesc = Livebook - Automate code & data workflows with interactive Elixir notebooks
- pkgver = 0.7.2
- pkgrel = 2
+ pkgdesc = Automate code & data workflows with interactive Elixir notebooks
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://livebook.dev
arch = x86_64
- depends = openssl
- depends = erlang
+ license = Apache-2.0
+ makedepends = git
+ makedepends = rebar3
depends = elixir
+ depends = erlang-nox
pkgname = livebook
diff --git a/PKGBUILD b/PKGBUILD
index 6054e963d3b9..6a0ca288968e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,19 @@ pkgname="livebook"
pkgver="0.9.2"
pkgrel="1"
pkgdesc="Automate code & data workflows with interactive Elixir notebooks"
-arch=("x86_64")
url="https://livebook.dev"
-
-depends=('openssl' 'erlang' 'elixir')
+license=("Apache-2.0")
+arch=("x86_64")
+depends=("elixir" "erlang-nox")
+makedepends=('git' 'rebar3')
# sha256sums=("SKIP")
build() {
- /usr/bin/mix do local.rebar --force, local.hex --force
- /usr/bin/mix escript.install hex livebook 0.7.2
+ /usr/bin/mix local.hex --force
+ /usr/bin/mix local.rebar --force
+
+ /usr/bin/mix escript.install hex livebook "$pkgver"
}
check() {