summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNelson Estevão2023-04-22 17:56:08 +0100
committerNelson Estevão2023-04-22 17:56:08 +0100
commitdf817a75a4385b7b0cd52b7ce67264b87b73d1f6 (patch)
treea0d3f75a74d0ba548b906dc1d13f1547a9f6c9e4
parent94f4a10147a39f6ff3410a59dffa912e680f187b (diff)
downloadaur-df817a75a4385b7b0cd52b7ce67264b87b73d1f6.tar.gz
Fix error on build package when people use asdf globally
-rw-r--r--PKGBUILD5
-rw-r--r--build.sh2
2 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8540540029eb..e6d4270033ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# Maintainer: Nelson Estevão <nelson@marmelasoft.com>
pkgname="livebook"
pkgver="0.7.2"
pkgrel="1"
@@ -10,8 +9,8 @@ depends=('openssl' 'erlang' 'elixir')
# sha256sums=("SKIP")
build() {
- mix do local.rebar --force, local.hex --force
- mix escript.install hex livebook 0.7.2
+ /usr/bin/mix do local.rebar --force, local.hex --force
+ /usr/bin/mix escript.install hex livebook 0.7.2
}
package() {
diff --git a/build.sh b/build.sh
new file mode 100644
index 000000000000..fa1a2155ebfd
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,2 @@
+makepkg --source -f
+makepkg --printsrcinfo > .SRCINFO