summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNelson Estevão2023-04-24 09:49:48 +0100
committerNelson Estevão2023-04-24 09:49:48 +0100
commite5c808b3ab2c88e96b24d81513d6d8c41f94e30b (patch)
tree9e5cb6c5d51b7b56b6ab283380151a3dd5ddcde6
parent3a21f88b81a449338e7acea1922fdaa7b3e197c4 (diff)
downloadaur-e5c808b3ab2c88e96b24d81513d6d8c41f94e30b.tar.gz
Improve package fields
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44dd82b5298e..6054e963d3b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,28 @@
+# Maintainer: Nelson Estevão <nelsonmestevao@proton.me>
+
pkgname="livebook"
-pkgver="0.7.2"
-pkgrel="2"
-pkgdesc="Livebook - Automate code & data workflows with interactive Elixir notebooks"
+pkgver="0.9.2"
+pkgrel="1"
+pkgdesc="Automate code & data workflows with interactive Elixir notebooks"
arch=("x86_64")
+url="https://livebook.dev"
depends=('openssl' 'erlang' 'elixir')
# sha256sums=("SKIP")
build() {
- /usr/bin/mix do local.rebar --force, local.hex --force
- /usr/bin/mix escript.install hex livebook 0.7.2
+ /usr/bin/mix do local.rebar --force, local.hex --force
+ /usr/bin/mix escript.install hex livebook 0.7.2
+}
+
+check() {
+ /usr/bin/livebook --version
}
package() {
- # Copy the installed package to the package directory
- sudo cp -r $HOME/.mix/escripts/livebook /usr/bin/
+ # Copy the installed package to the package directory
+ sudo cp -r $HOME/.mix/escripts/livebook /usr/bin/
}