summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneworld2018-09-19 09:57:40 +0300
committerneworld2018-09-19 09:57:40 +0300
commitde70480449d476df726e7837e1ce437729f90efe (patch)
treedd29543ddc4a89ee39df0b61c2f6e34d5b679e9f
downloadaur-livecv.tar.gz
Create livecv using 1.5.0 version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD51
-rw-r--r--livecv.in.patch91
3 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..528e80896eff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = livecv
+ pkgdesc = Computer vision coding environment that displays results in real time
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/livecv/livecv
+ arch = x86_64
+ license = LGPL3
+ makedepends = qt5-base
+ depends = opencv
+ depends = qt5-quickcontrols
+ provides = livecv
+ source = livecv-1.5.0.tar.gz::https://github.com/livecv/livecv/archive/v1.5.0.tar.gz
+ source = livecv.in.patch
+ sha256sums = c2cdb499c1c65538c049d6e776289b15f82b599f4a551cb4d37013981ffc254b
+ sha256sums = 87993897bb93921053a8fc9e85a11827172f4ca56879c3955b925ef1b59328eb
+
+pkgname = livecv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b42618bd89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: newordLT <aneworld [at] gmail [DoT] com>
+
+pkgname=livecv
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Computer vision coding environment that displays results in real time"
+arch=('x86_64')
+url="https://github.com/livecv/${pkgname}"
+license=('LGPL3')
+depends=("opencv" "qt5-quickcontrols")
+makedepends=("qt5-base")
+source=("livecv-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "livecv.in.patch")
+sha256sums=('c2cdb499c1c65538c049d6e776289b15f82b599f4a551cb4d37013981ffc254b'
+ '87993897bb93921053a8fc9e85a11827172f4ca56879c3955b925ef1b59328eb')
+provides=('livecv')
+
+prepare () {
+ cd "${srcdir}/livecv-${pkgver}"
+
+ patch -p1 -i "${srcdir}/livecv.in.patch"
+}
+
+build() {
+ cd "$srcdir/livecv-${pkgver}"
+
+ qmake -r
+ make
+}
+
+package() {
+ cd "${srcdir}/livecv-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/lib"
+ mkdir -p "${pkgdir}/usr/lib/livecv"
+ mkdir -p "${pkgdir}/usr/lib/livecv/link"
+
+ cp bin/lib*.so "${pkgdir}/usr/lib/"
+ cp -r bin/* "${pkgdir}/usr/lib/livecv/"
+
+ ln -r -s "${pkgdir}/usr/lib/livecv/plugins/editor/libeditor.so" "${pkgdir}/usr/lib/livecv/link/libeditor.so"
+ ln -r -s "${pkgdir}/usr/lib/livecv/plugins/lcvcore/liblcvcore.so" "${pkgdir}/usr/lib/livecv/link/liblcvcore.so"
+ ln -r -s "${pkgdir}/usr/lib/livecv/plugins/lcvfeatures2d/liblcvfeatures2d.so" "${pkgdir}/usr/lib/livecv/link/liblcvfeatures2d.so"
+ ln -r -s "${pkgdir}/usr/lib/livecv/plugins/lcvimgproc/liblcvimgproc.so" "${pkgdir}/usr/lib/livecv/link/liblcvimgproc.so"
+ ln -r -s "${pkgdir}/usr/lib/livecv/plugins/lcvphoto/liblcvphoto.so" "${pkgdir}/usr/lib/livecv/link/liblcvphoto.so"
+ ln -r -s "${pkgdir}/usr/lib/livecv/plugins/lcvvideo/liblcvvideo.so" "${pkgdir}/usr/lib/livecv/link/liblcvvideo.so"
+ ln -r -s "${pkgdir}/usr/lib/livecv/plugins/live/liblive.so" "${pkgdir}/usr/lib/livecv/link/liblive.so"
+
+ ln -r -s "${pkgdir}/usr/lib/livecv/livecv" "${pkgdir}/usr/bin/livecv"
+}
diff --git a/livecv.in.patch b/livecv.in.patch
new file mode 100644
index 000000000000..f7200571341a
--- /dev/null
+++ b/livecv.in.patch
@@ -0,0 +1,91 @@
+From 3bac9e9f6db55fd2ed5c37751a5236780fa16d97 Mon Sep 17 00:00:00 2001
+From: neworld <aneworld@gmail.com>
+Date: Tue, 18 Sep 2018 21:29:46 +0300
+Subject: [PATCH] Compiliation error
+
+---
+ lib/lvbase/3rdparty/backward/backward.hpp | 2 +-
+ lib/lvbase/src/libraryloadpath_unix.cpp | 2 +-
+ lib/lvbase/src/plugincontext.cpp | 13 +++++++++++--
+ lib/lvbase/src/plugincontext.h | 1 +
+ 4 files changed, 14 insertions(+), 4 deletions(-)
+
+diff --git a/lib/lvbase/3rdparty/backward/backward.hpp b/lib/lvbase/3rdparty/backward/backward.hpp
+index 782ff90..2d99e3a 100644
+--- a/lib/lvbase/3rdparty/backward/backward.hpp
++++ b/lib/lvbase/3rdparty/backward/backward.hpp
+@@ -1975,7 +1975,7 @@ public:
+ SIGSEGV, // Invalid memory reference
+ SIGSYS, // Bad argument to routine (SVr4)
+ SIGTRAP, // Trace/breakpoint trap
+- SIGUNUSED, // Synonymous with SIGSYS
++ SIGSYS, // Synonymous with SIGSYS
+ SIGXCPU, // CPU time limit exceeded (4.2BSD)
+ SIGXFSZ, // File size limit exceeded (4.2BSD)
+ };
+diff --git a/lib/lvbase/src/libraryloadpath_unix.cpp b/lib/lvbase/src/libraryloadpath_unix.cpp
+index 9fdba55..db7f055 100644
+--- a/lib/lvbase/src/libraryloadpath_unix.cpp
++++ b/lib/lvbase/src/libraryloadpath_unix.cpp
+@@ -37,7 +37,7 @@ bool assertLinkPathExists(const QString& linkPath){
+
+ void LibraryLoadPath::addImpl(const QString& path, const QString& linkPath, bool recursive){
+ if ( !assertLinkPathExists(linkPath) ){
+- qCritical("Failed to create link directory. Some library dependencies may fail to load.");
++ qCritical("Failed to create link directory (%s -> %s). Some library dependencies may fail to load.", path.toLatin1().constData(), linkPath.toLatin1().constData());
+ return;
+ }
+
+diff --git a/lib/lvbase/src/plugincontext.cpp b/lib/lvbase/src/plugincontext.cpp
+index d5a9bff..8313b38 100644
+--- a/lib/lvbase/src/plugincontext.cpp
++++ b/lib/lvbase/src/plugincontext.cpp
+@@ -52,6 +52,15 @@ QString PluginContext::applicationPath(){
+ #endif
+ }
+
++QString PluginContext::homePath() {
++ QString homePath = QDir::homePath() + "/.livecv";
++
++ QDir dir = QDir::root();
++ dir.mkpath(homePath);
++
++ return homePath;
++}
++
+ QString PluginContext::applicationFilePath(){
+ if ( m_applicationFilePath.isEmpty() )
+ m_applicationFilePath = applicationFilePathImpl();
+@@ -71,7 +80,7 @@ QString PluginContext::pluginPath(){
+ #ifdef Q_OS_DARWIN
+ return applicationPath() + "/PlugIns";
+ #else
+- return applicationPath() + "/plugins";
++ return "/usr/lib/livecv/plugins";
+ #endif
+ }
+
+@@ -100,7 +109,7 @@ QString PluginContext::developmentPath(){
+ }
+
+ QString PluginContext::configPath(){
+- return applicationPath() + "/config";
++ return homePath() + "/config";
+ }
+
+
+diff --git a/lib/lvbase/src/plugincontext.h b/lib/lvbase/src/plugincontext.h
+index 26f52b6..184144a 100644
+--- a/lib/lvbase/src/plugincontext.h
++++ b/lib/lvbase/src/plugincontext.h
+@@ -36,6 +36,7 @@ public:
+
+ static QString executableDirPath();
+ static QString applicationPath();
++ static QString homePath();
+ static QString applicationFilePath();
+ static QString linkPath();
+ static QString pluginPath();
+--
+2.19.0
+