summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2016-07-06 13:52:28 +0100
committerAngelo Theodorou2016-07-06 13:52:28 +0100
commit07f64f5ecc0003d87379aebd3195b5e71b15689c (patch)
tree93b695bc56501c27e56ce6d715cd7ae4bf1db0e1
parent453d5d29bc63457d703e516db5e85b5dc4609148 (diff)
downloadaur-07f64f5ecc0003d87379aebd3195b5e71b15689c.tar.gz
Remove deprecated options and commands from PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--lives.changelog8
3 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80e4d944021f..6f9341cbe4e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jul 4 12:40:13 UTC 2016
+# Wed Jul 6 12:50:14 UTC 2016
pkgbase = lives
pkgdesc = A Video Editing System
pkgver = 2.6.3
- pkgrel = 1
+ pkgrel = 2
url = http://lives-video.com
changelog = lives.changelog
arch = i686
@@ -31,7 +31,7 @@ pkgbase = lives
optdepends = cdrkit
optdepends = lame
optdepends = youtube-dl
- options = !libtool
+ options = !emptydirs
source = http://lives-video.com/releases/LiVES-2.6.3.tar.bz2
md5sums = b5fad0838b180902f8304b1978bbac41
diff --git a/PKGBUILD b/PKGBUILD
index f4c44c70b8a4..28d4daca5f99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,26 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=lives
pkgver=2.6.3
-pkgrel=1
+pkgrel=2
pkgdesc="A Video Editing System"
arch=('i686' 'x86_64')
url="http://lives-video.com"
license=('GPL')
depends=('mplayer' 'imagemagick' 'gtk3' 'sox' 'libvisual' 'liboil' 'libavc1394' 'mjpegtools' 'python' 'ffmpeg2.8' 'jack' 'fftw')
optdepends=('xorg-utils' 'sdl' 'libogg' 'mkvtoolnix-cli' 'libmatroska' 'ogmtools' 'dvgrab' 'cdrkit' 'lame' 'youtube-dl')
-options=(!libtool)
+options=(!emptydirs)
changelog=lives.changelog
source=(http://lives-video.com/releases/LiVES-$pkgver.tar.bz2)
md5sums=('b5fad0838b180902f8304b1978bbac41')
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
- # /bin/touch -> /usr/bin/touch
- find -type f -exec sed -i 's:/bin/touch:/usr&:g' {} \;
+ cd $pkgname-$pkgver
PKG_CONFIG_PATH=/usr/lib/ffmpeg2.8/pkgconfig\
./configure --prefix=/usr --enable-turbo
make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
-
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
- rm "$pkgdir"/usr/bin/lives
- ln -s /usr/bin/lives-exe "$pkgdir"/usr/bin/lives
-
- rmdir "$pkgdir"/usr/share/doc/lives-2.6.3/html/libweed
- rmdir "$pkgdir"/usr/share/lives/plugins/effects/compound/icons
- rmdir "$pkgdir"/usr/lib/lives/plugins/effects/realtime/weed/icons
}
diff --git a/lives.changelog b/lives.changelog
index 83cc70ef877a..a22c33114b85 100644
--- a/lives.changelog
+++ b/lives.changelog
@@ -1,3 +1,11 @@
+2016-07-06 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Removed "!libtool" option and added "!emptydirs
+ Removed the fix to call the touch command
+ Removed the command to create a symlink to the executable
+ Deleted commands to remove empty directories from the package
+
2016-07-04 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD :