summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2016-11-20 16:12:31 +0000
committerAngelo Theodorou2016-11-20 16:12:31 +0000
commitc6a75e0c832cf6f96443fae4e28999a9fdbf64e3 (patch)
treeab111faf0d9e994da3f6b99b3a875bfd36bbae52
parentaab96431b8edcf22a420a9c7ace7d02145f8c150 (diff)
downloadaur-c6a75e0c832cf6f96443fae4e28999a9fdbf64e3.tar.gz
Add again a patch to disable toonz
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--disable-toonz.patch17
-rw-r--r--lives.changelog5
4 files changed, 38 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab30f4d1d64d..e7cb9071ae34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Nov 5 13:05:30 UTC 2016
+# Sun Nov 20 16:11:41 UTC 2016
pkgbase = lives
pkgdesc = A Video Editing System
pkgver = 2.8.1
- pkgrel = 1
+ pkgrel = 2
url = http://lives-video.com
changelog = lives.changelog
arch = i686
arch = x86_64
license = GPL
+ makedepends = automake
depends = mplayer
depends = imagemagick
depends = gtk3
@@ -34,7 +35,9 @@ pkgbase = lives
optdepends = opencv
options = !emptydirs
source = http://lives-video.com/releases/LiVES-2.8.1.tar.bz2
+ source = disable-toonz.patch
md5sums = 5ead5834902b3b6962a72627e584ae87
+ md5sums = dffab836d4dc5a277c67450e2b1b810b
pkgname = lives
diff --git a/PKGBUILD b/PKGBUILD
index 8d7fffceb105..71b5a54d2473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=lives
pkgver=2.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Video Editing System"
arch=('i686' 'x86_64')
url="http://lives-video.com"
license=('GPL')
depends=('mplayer' 'imagemagick' 'gtk3' 'sox' 'libvisual' 'liboil' 'mjpegtools' 'python' 'ffmpeg2.8' 'jack' 'fftw')
optdepends=('xorg-utils' 'sdl' 'libogg' 'mkvtoolnix-cli' 'libmatroska' 'ogmtools' 'libavc1394' 'dvgrab' 'cdrkit' 'lame' 'youtube-dl' 'opencv')
+makedepends=('automake')
options=(!emptydirs)
changelog=lives.changelog
-source=(http://lives-video.com/releases/LiVES-$pkgver.tar.bz2)
-md5sums=('5ead5834902b3b6962a72627e584ae87')
+source=(http://lives-video.com/releases/LiVES-$pkgver.tar.bz2 disable-toonz.patch)
+md5sums=('5ead5834902b3b6962a72627e584ae87' 'dffab836d4dc5a277c67450e2b1b810b')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ # with opencv installed, toonz.cpp failes to build
+ patch -p1 -i "${srcdir}/disable-toonz.patch"
+ automake
+}
build() {
cd ${pkgname}-${pkgver}
diff --git a/disable-toonz.patch b/disable-toonz.patch
new file mode 100644
index 000000000000..794e5595022e
--- /dev/null
+++ b/disable-toonz.patch
@@ -0,0 +1,17 @@
+--- old/lives-plugins/weed-plugins/Makefile.am.org 2016-10-23 01:03:56.000000000 +0200
++++ new/lives-plugins/weed-plugins/Makefile.am 2016-11-07 00:25:36.907891417 +0100
+@@ -89,14 +89,7 @@
+ farneback_analyser_la_CPPFLAGS = $(AM_CPPFLAGS)
+ farneback_analyser_la_SOURCES = farneback_analyser.cpp
+
+-if ENABLE_TOONZ
+-toonz_libs = toonz.la
+-toonz_la_LDFLAGS = $(AM_LDFLAGS) $(OPENCV_LIBS_ONLY_L) -lopencv_core -lopencv_imgproc
+-toonz_la_CPPFLAGS = $(AM_CPPFLAGS) -std=c++11
+-toonz_la_SOURCES = toonz.cpp
+-else
+ toonz_libs =
+-endif
+
+ opencvlibdir = "$(libdir)/$(PACKAGE)/plugins/effects/realtime/weed"
+ opencvlib_LTLIBRARIES = $(farneback_analyser_libs) $(toonz_libs)
diff --git a/lives.changelog b/lives.changelog
index e2dd837dd1f9..8e6abd66e249 100644
--- a/lives.changelog
+++ b/lives.changelog
@@ -1,3 +1,8 @@
+2016-11-20 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Disable toonz patch added again as it is still needed
+
2016-11-05 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD :