summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Rakel2015-11-20 10:51:03 +0100
committerSebastian Rakel2015-11-20 11:38:43 +0100
commit5ded55118c9a4b04b0f8e778b26911f83b079a99 (patch)
tree94d95f61b4f8a5fd1d162528f350661ec67ae365
downloadaur-5ded55118c9a4b04b0f8e778b26911f83b079a99.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79245bcb53fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = livestreamer-dev-git
+ pkgdesc = CLI program that launches streams from various streaming services in a custom video player
+ pkgver = 0.r1431.8dd6a69
+ pkgrel = 1
+ url = https://github.com/chrippa/livestreamer
+ arch = any
+ license = BSD
+ makedepends = python-sphinx
+ depends = python-requests
+ depends = rtmpdump
+ depends = python-setuptools
+ provides = livestreamer
+ conflicts = livestreamer
+ source = livestreamer-dev-git::git+https://github.com/chrippa/livestreamer#branch=develop
+ sha256sums = SKIP
+
+pkgname = livestreamer-dev-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c8df811d197
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+livestreamer-dev-git-*-any.pkg.tar.xz
+*.pcf.gz
+livestreamer-dev-git/
+*.bdf.bak
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2a719902bca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sebastian Rakel <sebastian@devunit.eu>
+# Contributor: Christopher Rosell <chrippa@tanuki.se>
+
+_pkgname='livestreamer'
+pkgname="${_pkgname}-dev-git"
+pkgver=0.r1431.8dd6a69
+pkgrel=1
+pkgdesc='CLI program that launches streams from various streaming services in a custom video player'
+arch=('any')
+url='https://github.com/chrippa/livestreamer'
+license=('BSD')
+depends=('python-requests' 'rtmpdump' 'python-setuptools')
+makedepends=('python-sphinx')
+source=("${pkgname}::git+https://github.com/chrippa/livestreamer#branch=develop")
+sha256sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${pkgname}"
+ printf '0.r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python setup.py build_sphinx -b man
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 build/sphinx/man/livestreamer.1 \
+ "$pkgdir/usr/share/man/man1/livestreamer.1"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}