summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Rødseth2019-02-14 18:46:08 +0000
committerAlexander Rødseth2019-02-14 18:46:08 +0000
commit13d65786925e40dd2ffe0b9d4908e23ff390c1b8 (patch)
treec66887f5361b53180936b192a087cf60650eb828
downloadaur-13d65786925e40dd2ffe0b9d4908e23ff390c1b8.tar.gz
New package
livewallpaper-bzr has 14 votes on AUR
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ab80b951beb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Salamandar <felix@piedallu.me>
+
+pkgname=livewallpaper
+pkgver=0.5.0.333
+pkgrel=1
+pkgdesc='Animated 3D wallpapers'
+url='https://launchpad.net/livewallpaper'
+license=(GPL3)
+arch=(x86_64)
+makedepends=(bzr cmake intltool ninja vala xcftools)
+depends=(glew gobject-introspection libappindicator-gtk3 libpeas python-cairo python-opengl upower)
+source=("$pkgname::bzr+$url/trunk#revision=${pkgver##*.}")
+sha256sums=('SKIP')
+
+prepare() {
+ sed -i '/debian/d' $pkgname/CMakeLists.txt
+ sed -i "s/--quiet/--quiet --cflags-begin $CFLAGS --cflags-end/g" \
+ $pkgname/$pkgname-core/CMakeLists.txt
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="$CFLAGS -O2 -fPIC -w" \
+ -DENABLE_OPTIMIZATION=on \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -G Ninja
+ ninja
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+# getver: launchpad.net/livewallpaper/+download
+# vim: ts=2 sw=2 et: