summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFélix Piédallu2019-02-02 20:15:26 +0100
committerFélix Piédallu2019-02-02 20:15:26 +0100
commit56d98c925d99d430eb6fed13c399f4fd93310782 (patch)
tree0e3cc12aba2197f63244966a3e3eb1f429484fe4
parent35ad5dd0a635cf4f3b949a06c006286b0b8ad224 (diff)
downloadaur-56d98c925d99d430eb6fed13c399f4fd93310782.tar.gz
push to trunk, fix build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
-rw-r--r--livewallpaper.patch53
3 files changed, 29 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60be0a7b417a..785d52e9e40e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
-# Generated by mksrcinfo v8
-# Fri Aug 18 11:45:30 UTC 2017
pkgbase = livewallpaper
pkgdesc = OpenGL powered animated wallpapers with configuration utility, autostart, and application indicator.
- pkgver = 0.5.0
- pkgrel = 3
+ pkgver = 0.5.0.r333
+ pkgrel = 1
url = https://launchpad.net/livewallpaper
arch = x86_64
arch = i686
license = GPL3
- makedepends = intltool
- makedepends = xcftools
+ makedepends = bzr
makedepends = cmake
+ makedepends = ninja
makedepends = vala
+ makedepends = intltool
+ makedepends = xcftools
depends = libpeas
depends = upower
depends = libappindicator-gtk3
@@ -20,10 +20,8 @@ pkgbase = livewallpaper
depends = python-cairo
depends = python-opengl
depends = glew
- source = https://launchpad.net/livewallpaper/0.5/0.5.0/+download/livewallpaper-0.5.0.tar.gz
- source = livewallpaper.patch
- sha256sums = f4ce97a721015b135eb675915eb306c1fb256e680d480fe13e4fe6ca81c7e04e
- sha256sums = 09945264707109bbebca632b40a7607b3ef882fe2fadd15d235f18ef0763a279
+ source = livewallpaper::bzr+https://launchpad.net/livewallpaper/trunk
+ sha256sums = SKIP
pkgname = livewallpaper
diff --git a/PKGBUILD b/PKGBUILD
index b905efd4d18d..b50f58f13cca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,51 +5,46 @@ pkgdesc="OpenGL powered animated wallpapers with configuration utility, autostar
url="https://launchpad.net/livewallpaper"
license=('GPL3')
-pkgver=0.5.0
-pkgrel=3
+pkgver=0.5.0.r333
+pkgrel=1
arch=('x86_64' 'i686')
-makedepends=('intltool' 'xcftools' 'cmake' 'vala')
+makedepends=(
+ 'bzr' 'cmake' 'ninja' 'vala' 'intltool' 'xcftools'
+)
depends=(
'libpeas' 'upower' 'libappindicator-gtk3' 'gobject-introspection'
'python' 'python-cairo' 'python-opengl' 'glew'
)
source=(
- 'https://launchpad.net/livewallpaper/0.5/0.5.0/+download/livewallpaper-0.5.0.tar.gz'
- 'livewallpaper.patch'
+ "${pkgname}"::'bzr+https://launchpad.net/livewallpaper/trunk'
)
sha256sums=(
- 'f4ce97a721015b135eb675915eb306c1fb256e680d480fe13e4fe6ca81c7e04e'
- '09945264707109bbebca632b40a7607b3ef882fe2fadd15d235f18ef0763a279'
+ 'SKIP'
)
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- # Patches:
- # * Please use python3
- # * Fix ref
- # * Fix old API (fromstring/tostring to frombytes/tobytes)
- # * CMake : remove debian dir
- # * CMake : disable doc generation (needs gtk-doc)
- patch -p1 -l -i "${srcdir}/livewallpaper.patch"
+pkgver() {
+ cd "${pkgname}"
+ bzr tags | sort -n -k1 | sed 's/.*-//g'| awk -v REV="$(bzr revno)" 'END { printf("%s.r%s\n", $1, REV-$3) }'
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- rm -rf "build"
- mkdir "build"
- pushd "build" >/dev/null
+ cd "${pkgname}"
+ mkdir "build" -p
+ cd "build"
+
+ cmake -GNinja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make DESTDIR="${pkgdir}"
+ ninja
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- pushd "build" >/dev/null
+ cd "${pkgname}"
+ cd "build"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
diff --git a/livewallpaper.patch b/livewallpaper.patch
deleted file mode 100644
index 08119bc475bb..000000000000
--- a/livewallpaper.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -66,10 +66,8 @@ add_subdirectory(cmake)
- add_subdirectory(ui)
- add_subdirectory(po)
- add_subdirectory(plugins)
--add_subdirectory(doc)
- add_subdirectory(tools)
-
--add_subdirectory(debian)
-
- livewallpaper_plugin_post_install()
-
-diff --git a/plugins/circles/circles.py b/plugins/circles/circles.py
---- a/plugins/circles/circles.py
-+++ b/plugins/circles/circles.py
-@@ -1,3 +1,4 @@
-+#!/usr/bin/python3
- #
- #
- # Livewallpaper
-diff --git a/plugins/photoslide/photoslide.py b/plugins/photoslide/photoslide.py
---- a/plugins/photoslide/photoslide.py
-+++ b/plugins/photoslide/photoslide.py
-@@ -1,3 +1,4 @@
-+#!/usr/bin/python3
- #
- #
- # Livewallpaper Photoslide Plugins
-@@ -205,8 +206,8 @@ class PhotoslidePlugin(GObject.Object, LW.Wallpaper):
- if pixbuf:
- width = pixbuf.get_width()
- height = pixbuf.get_height()
-- img = Image.fromstring("RGBA", (width, height), pixbuf.get_pixels())
-- imgarr = array.array("B", img.convert("RGBA").tostring("raw", "BGRA"))
-+ img = Image.frombytes("RGBA", (width, height), pixbuf.get_pixels())
-+ imgarr = array.array("B", img.convert("RGBA").tobytes("raw", "BGRA"))
- imgsurface = cairo.ImageSurface.create_for_data(imgarr, cairo.FORMAT_ARGB32, width, height, width * 4)
- cr.set_source_surface(imgsurface, (self.img_width - width) / 2, (self.img_height - height) / 2)
- cr.paint()
-diff --git a/ui/config/files-selector.vala b/ui/config/files-selector.vala
---- a/ui/config/files-selector.vala
-+++ b/ui/config/files-selector.vala
-@@ -55,7 +55,7 @@ public class FilesSelector : Box {
- if (ts.count_selected_rows () > 0) {
- TreeIter it;
- ts.get_selected (null, out it);
-- model.remove (it);
-+ model.remove(ref it);
- value_changed (this.get_values());
- }
- }