summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Archive Bot2015-08-16 21:37:03 +0200
committerAUR Archive Bot2015-08-16 21:37:03 +0200
commit937c1db19578d80f49e4cf5f0adaea4d6afba6c4 (patch)
tree9984ee6622f8b8ff441361f635cb0d5d84882591
downloadaur-937c1db19578d80f49e4cf5f0adaea4d6afba6c4.tar.gz
Initial AUR Archive commit of 'livewallpaper'
(full history will be added later)
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD25
-rw-r--r--livewallpaper.install11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..560c67e2a3d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by makepkg 4.2.1
+# Wed Apr 8 22:38:26 UTC 2015
+pkgbase = livewallpaper
+ pkgdesc = OpenGL powered animated wallpapers with configuration utility, autostart, and application indicator.
+ pkgver = 0.4.1
+ pkgrel = 2
+ url = https://launchpad.net/livewallpaper
+ install = livewallpaper.install
+ arch = any
+ license = GPL3
+ makedepends = intltool
+ makedepends = xcftools
+ depends = libgl
+ depends = gtk3
+ depends = libpeas
+ depends = libx11
+ depends = python-cairo
+ depends = python-opengl
+ provides = livewallpaper
+ provides = livewallpaper-indicator
+ provides = livewallpaper-config
+ source = https://launchpad.net/livewallpaper/0.4/0.4.1/+download/livewallpaper-0.4.1.tar.gz
+ sha256sums = 9b1e386ce0aa0547d8ac9938a8d3f211cffd8b38496bf1972a99455d94bd2de6
+
+pkgname = livewallpaper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ccf14391397
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=livewallpaper
+pkgver=0.4.1
+pkgrel=2
+pkgdesc="OpenGL powered animated wallpapers with configuration utility, autostart, and application indicator."
+arch=(any)
+url="https://launchpad.net/livewallpaper"
+license=('GPL3')
+depends=('libgl' 'gtk3' 'libpeas' 'libx11' 'python-cairo' 'python-opengl')
+makedepends=('intltool' 'xcftools')
+provides=('livewallpaper' 'livewallpaper-indicator' 'livewallpaper-config')
+source=(https://launchpad.net/livewallpaper/0.4/0.4.1/+download/livewallpaper-0.4.1.tar.gz)
+sha256sums=(9b1e386ce0aa0547d8ac9938a8d3f211cffd8b38496bf1972a99455d94bd2de6)
+install=livewallpaper.install
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/cmake"
+ sed -i "s/set(LIVEWALLPAPER_REQUIRES\
+/&\n\tx11/" ../CMakeLists.txt
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ../
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/cmake"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/livewallpaper.install b/livewallpaper.install
new file mode 100644
index 000000000000..184f8b886ad9
--- /dev/null
+++ b/livewallpaper.install
@@ -0,0 +1,11 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}