summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2023-06-20 11:50:42 +0200
committerLucki2023-06-20 11:50:42 +0200
commit133584966475f37430c85591b80e752c83146e50 (patch)
tree7cbf28676cf4dc1acb5913dbdecf2186ad78011e
parenta79e130670874005066ab4d21cf0006242a62aee (diff)
downloadaur-133584966475f37430c85591b80e752c83146e50.tar.gz
upgpkg: lix 0.10.12-1
upstream release
-rw-r--r--.CHANGELOG49
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
3 files changed, 59 insertions, 12 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index a7e5b527d534..68242cdfa66d 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,55 @@
Version history
===============
+0.10.12
+-------
+
+2023-06-19
+
+Fix #375: Changing sound/music in the options menu will immediately play an
+example sound or the menu music at the new volume setting. You don't have to
+exit the options menu anymore to test.
+
+Fix #466: When the next level is unplayable, e.g., it lacks hatches, you
+can't run it from the next-level menu. Before, you could, and Lix crashed.
+
+Added four boolean user options: With/without the tweaker, should air clicks
+cancel the replay, and should new assignments insert or cut the replay?
+Without the tweaker, the default remains that both air clicks and new
+assignments cancel the replay. With the tweaker, by default, air clicks do
+nothing and new assignments insert.
+
+During play, the tooltip line is separate from the panel's info bar. Tooltips
+appear over the play area and have a darkened background. I hope that new
+players can now see easily: "Replaying. To play yourself, click into air."
+
+Removed the zoom button from game and editor. Everybody zooms with the mouse
+wheel, and the zoom button would zoom into the mouse cursor on the panel, thus
+oddly fixing a point on the map outside the camera. For now, the game's
+restart button is wider to cover the area of the old zoom button.
+
+Revert mouse trapping to how it was in Lix 0.10.7 and earlier: We trap the
+mouse already on mouseover when the Lix window is active.
+
+Remove the steel tile matt/8x8. This tile had no nub, had no crossed metal
+bars, and looked like geoo's concrete blocks which are earth. Remove it with
+no replacement. We'll look separately at all levels that used it.
+
+Won't Get Fooled Again: Replace important 8x8 steel with a nice-looking tile
+group to make a steel staircase. Physics stay exactly the same.
+
+All Aboard the Pain Train: Remove purely decorative 8x8 steel.
+
+Sympathy for the Lix, Race to the Depths: Remove these multiplayer levels
+with 8x8 steel. Sympathy relied on other players' mistakes. Race was too hard.
+
+Removed an undocumented feature: You could place a file gain.txt into
+music/ to change the volume of tracks.
+
+Fixed compiler warnings from DMD 2.104.0: Change "in ref" to "in".
+
+
+
0.10.11
-------
diff --git a/.SRCINFO b/.SRCINFO
index 61d3d901caf6..862aa0511acd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.10.11
+ pkgver = 0.10.12
pkgrel = 1
url = https://www.lixgame.com/
changelog = .CHANGELOG
@@ -8,13 +8,13 @@ pkgbase = lix
arch = x86_64
license = custom:CC0
makedepends = git
- makedepends = ldc
+ makedepends = d-compiler
makedepends = dub
depends = allegro
depends = enet
depends = hicolor-icon-theme
- depends = liblphobos
- source = lix-0.10.11.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.10.11.tar.gz
+ depends = d-runtime
+ source = lix-0.10.12.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.10.12.tar.gz
source = lix-music-1.1.zip::https://www.lixgame.com/dow/lix-music.zip
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
source = lix-bolts::git+https://github.com/aliak00/bolts.git#tag=v1.3.1
@@ -25,7 +25,7 @@ pkgbase = lix
source = lix-sdlang-d::git+https://github.com/Abscissa/SDLang-D.git#tag=v0.10.6
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.22
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = 322807d4eb4a02c8a86ebaa3da621b5c6e3093c6d4c0568870c5b71b0c3f35579dd775fa6d42e7c54e1fec106dee82a5293e00497208468a38518f6e0c8dc3e1
+ sha512sums = 1968969759ee24887acd88af9d6bd1b322d36b72aaa9657ccfcda5db35f63049f6e61975578842f72382858d0a65c706d011bc9844637409257466e4116f8e52
sha512sums = 280fd25a479ac8dd24475b014234270a12ab34edca7fb2f7ce4b768259111b1e7626d3ba37ac13d810f0653d23d7c9f212776e94d2c0b31a0de580864771ce9f
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 428eb29ab42b..7700cf9b4739 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki>
# Contributor: Carl Reinke <mindless2112 gmail com>
# shellcheck shell=bash
-# shellcheck disable=2034,2154
+# shellcheck disable=SC2034,SC2154
pkgname=lix
-pkgver=0.10.11
+pkgver=0.10.12
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz"
"$pkgname-music-1.1.zip::https://www.lixgame.com/dow/lix-music.zip")
-sha512sums=('322807d4eb4a02c8a86ebaa3da621b5c6e3093c6d4c0568870c5b71b0c3f35579dd775fa6d42e7c54e1fec106dee82a5293e00497208468a38518f6e0c8dc3e1'
+sha512sums=('1968969759ee24887acd88af9d6bd1b322d36b72aaa9657ccfcda5db35f63049f6e61975578842f72382858d0a65c706d011bc9844637409257466e4116f8e52'
'280fd25a479ac8dd24475b014234270a12ab34edca7fb2f7ce4b768259111b1e7626d3ba37ac13d810f0653d23d7c9f212776e94d2c0b31a0de580864771ce9f')
_gitname=LixD
@@ -17,8 +17,8 @@ pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="https://www.lixgame.com/"
license=('custom:CC0')
-depends=('allegro' 'enet' 'hicolor-icon-theme' 'liblphobos')
-makedepends=('git' 'ldc' 'dub')
+depends=('allegro' 'enet' 'hicolor-icon-theme' 'd-runtime')
+makedepends=('git' 'd-compiler' 'dub')
_dubv=( "4.0.4+5.2.0" # allegro
"1.3.1" # bolts
"4.2.0" # derelict-enet
@@ -74,8 +74,6 @@ _build() {
--parallel \
`# Forces a recompilation even if the target is up to date:` \
--force \
- `# Specifies the compiler binary to use:` \
- --compiler=ldc \
`# force FHS compatibility:` \
--build=releaseXDG \
`# Save result code for later when failed:` \