summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2017-10-25 19:21:28 +0200
committerLucki2017-10-25 19:21:28 +0200
commit208c12b57d600d46096dfd41348254c4886fc056 (patch)
treec7d2f076c869facf411290e311a5d52014f3449e
parent824c8f471c0488343a284e808561eff26d3cb52f (diff)
downloadaur-208c12b57d600d46096dfd41348254c4886fc056.tar.gz
Update to v0.9.2
-rw-r--r--.CHANGELOG62
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD2
3 files changed, 57 insertions, 13 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index d50040ed4042..3638935b4b11 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,59 @@
Version history
===============
+0.9.2
+-----
+
+2017-10-22
+
+Rubix reordered his singleplayer levels and added the Community Collab
+Project: 4 levels in single/rubix/Extras.
+
+lemforum: Path to Mahiman, removed indirect jump backroute. Runaround up to
+Cunning, Raindow Road down to Quirky.
+
+Fix #252: Level search queries won't match the prefix 'levels/' in the
+filenames because all levels would match.
+
+Fix #256: When you export levels to images or save replays manually, the button replacement will not say "done", but instead tell you the filename.
+
+Fix #254: When you run out of VRAM during a level, the game won't crash, but
+instead stop making internal savestates. This won't display a warning, it will
+merely log. Recalculation due to incoming network packets will take longer,
+but that's better than crashing. The game remains VRAM-hungry and this
+solution is not ideal.
+
+0.9.1
+-----
+
+2017-10-05
+
+Fix #243: Sounds play in the lobby or browser when somebody joins or when
+somebody picks a map. When observers browse for maps and others start a game,
+the observer's browser closes, and the observer will see the game.
+
+Fix #244: Malformed UTF-8 in files within the level tree (e.g., zip archive)
+won't crash the Lix level search anymore. The offending file still will not
+appear as a searchable level; instead, the offending filename is logged. I
+validate all keyboard input for UTF-8.
+
+Fix #246: Tiles with coordinates far out-of-bounds crashed the editor once
+torus wrapping became enabled. Will now torus-wrap these tiles properly.
+
+Fix #247: The lix under the mouse is lighlighted far brighter and gets a dark
+outline to its left, right, and above it.
+
+Fix #248: Multiplayer colors: Purple is lighter. Black is darker. Yellow is
+darker and has less green hue.
+
+Removed a backroute in lemforum's Duality from abusing decoration.
+
+Added about 40 remakes by Proxima of maps from 2009. I've
+inserted the maps in their original authors' directories.
+
+Removed hidden water in Sharing the Water Supply 4p. Removed duplicate map
+files for Going Up 7p/8p.
+
0.9.0
-----
@@ -36,8 +89,6 @@ Fix #240: Observers don't have to cancel the end-of-game dialog anymore. I
print the game result to the console. This is not beautiful, but it's an
acceptable medium-term solution.
-
-
0.8.8
-----
@@ -64,8 +115,6 @@ Linux packaging: You can override the XDG install path with a custom path, see
doc/build/package.txt. In the git repository, data/images/lix_logo.svg has a
large logo as SVG. I don't ship that in the download because it's over 3 MB.
-
-
0.8.7
-----
@@ -75,8 +124,6 @@ The out-of-skills beep was too trigger-happy: When we clicked a mining lix
and had miners left in the skill panel, the game beeped as if we were out of
skills. Fixed.
-
-
0.8.6
-----
@@ -94,8 +141,6 @@ Included Rubix's variants on Marble Run, Eater Island, Diagonal 8p, and removed
Optionally print during play the number of physics updates, frames per second, and a ballpark guess of allocated VRAM.
-
-
0.8.5
-----
@@ -128,7 +173,6 @@ Fix #211: On Linux, you can pass a compiler switch to make Lix system-wide
installable, follwing the XDG base directory structure. For arbitrary
installation paths, open an issue on github.
-
0.8.4
-----
diff --git a/.SRCINFO b/.SRCINFO
index 339d63159e39..bb8de1410355 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Oct 5 20:22:08 UTC 2017
+# Wed Oct 25 17:19:54 UTC 2017
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.1
+ pkgver = 0.9.2
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -15,7 +15,7 @@ pkgbase = lix
makedepends = dub
depends = allegro
conflicts = lix-git
- source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.1
+ source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.2
sha512sums = SKIP
pkgname = lix
diff --git a/PKGBUILD b/PKGBUILD
index 47a188baecb5..afb65c062919 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix
-pkgver=0.9.1
+pkgver=0.9.2
pkgrel=1
conflicts=("${pkgname}-git")
source=(${pkgname}::git+https://github.com/SimonN/LixD.git#tag=v${pkgver})