summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2019-05-20 23:50:40 +0200
committerLucki2019-05-20 23:50:40 +0200
commit4622a6c64ea2f2bb7f0cb11cc2f19d4d36d0fff8 (patch)
tree22ec8cda5933218be61dbef53910585c08da41bb
parent33025ed042df865eaa50e57d0ec850142b15e57d (diff)
downloadaur-4622a6c64ea2f2bb7f0cb11cc2f19d4d36d0fff8.tar.gz
Update to v0.9.27
-rw-r--r--.CHANGELOG28
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
3 files changed, 31 insertions, 3 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 13c928d06d94..33064cfc4681 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,34 @@
Version history
===============
+0.9.27
+------
+
+2019-05-20
+
+Fixed a backroute in The Bottomless Closet, a miniature by geoo.
+
+Fix #379: The editor avoids cloning tiles outside of the map. Usually, the
+editor moves freshly-cloned tiles down-right by (16, 16). Sometimes, this
+would move tiles out of the map. New behavior: If a cloned tile would move out
+of the map, or even very close to the edge (= undercutting a safety margin of
+16 pixels), all cloned tiles are moved up-left by (16, 16) instead. If neither
+offset keeps all tiles on the map, we move down-right by (16, 16) and accept
+that some are outside. In torus directions, tiles are always on the map within
+the safety margin.
+
+Fix #380: While you change the background color in the editor's map dialog,
+the level behind the dialog previews your chosen color in real time. When
+you press OK, the color stays; when you press Cancel, the color reverts.
+
+Code: Fixed deprecations, now Lix compiles warning-free on dmd 2.086.0.
+
+Code: Removed module constructors and moved construction of user options
+into al_run_main. We hope to troubleshoot a segfault on macOS with this,
+github issue #381. Renamed DisplayTryMode to ScreenChoice.
+
+
+
0.9.26
------
diff --git a/.SRCINFO b/.SRCINFO
index 88db02b988b8..655c3e665401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.26
+ pkgver = 0.9.27
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,7 +14,7 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = liblphobos
- source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.26
+ source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.27
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
source = allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
diff --git a/PKGBUILD b/PKGBUILD
index fb106596e0c8..e8105bf6d0f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix
-pkgver=0.9.26
+pkgver=0.9.27
pkgrel=1
changelog=.CHANGELOG
source=("${pkgname}::git+https://github.com/SimonN/LixD.git#tag=v${pkgver}")