summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2018-01-05 00:33:24 +0100
committerLucki2018-01-05 00:33:24 +0100
commit4e7de2eb35067f13e9743e942708a2c8bdc14cc4 (patch)
tree004ad39f3463a8437c392e0ddee465d61dcfe1b5
parentc7cae772c0e893071861bf2cf5c1ba3325ca2741 (diff)
downloadaur-4e7de2eb35067f13e9743e942708a2c8bdc14cc4.tar.gz
Update to v0.9.7
-rw-r--r--.CHANGELOG48
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--build_fix.patch12
4 files changed, 80 insertions, 10 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 156643d57171..db59865f59e1 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,47 @@
Version history
===============
+0.9.7
+-----
+
+2018-01-03
+
+lemforum: Path to Mahiman, fixed backroute by early bashing.
+
+ClamLix: Swapped Inside the Fourth Wall with Urban Ledge-End. Applied mobius's
+fix to Square Squabble from 2017-12-28.
+
+Removed silent tile replacements, e.g., `moon.D' to `moon'. I've fixed about
+20 levels that still used outdated tile names. I will make a pull request
+against NepsterLix with these replacements.
+
+Fix #276: Replay browser prints the pointed-to filename, to avoid confusion
+what the pointedTo button does. I'd like to improve level-to-replay-matching
+further.
+
+Fix #278: Don't link against allegro_main on any system. Linking against that
+produced warnings on Windows and program-terminating errors during dynamic
+library loading on Mac.
+
+Fix #114: Don't index tiles at program start, allow adding tiles to the tree
+while Lix is running. This made the code far simpler. You still cannot change
+tiles while Lix is running because the file is read only once, then cached.
+
+Fix #275: When a basher ran out of earth to bash, some basher code ran on
+walker memory, failing asserts in debugging mode. I don't believe this fix
+changes physics, therefore no major version number bump.
+
+Fix #41: Options menu offers hardware fullscreen. This shouldn't be used
+normally, only when software fullscreen brings problems.
+
+Fix #238: Lobby uses radio buttons for choice of server. We hide the manual
+address field when central server is chosen.
+
+Fix: The level-to-image exporter crashed when called from the command line.
+
+Document where to download music in the main readme, in the detailed build
+notes, and in the notes for package maintainers.
+
0.9.6
-----
@@ -279,9 +320,12 @@ Fix #228: Edge scrolling requires the hardware mouse inside the window.
Fix #229: Pressing the hotkey of an empty skill deselects all skills instead
of keeping the previous selection.
-Included Rubix's variants on Marble Run, Eater Island, Diagonal 8p, and removed dead space on Across the Gap. Everybody else: Post your multiplayer maps, then I can include them in the next version.
+Included Rubix's variants on Marble Run, Eater Island, Diagonal 8p, and
+removed dead space on Across the Gap. Everybody else: Post your multiplayer
+maps, then I can include them in the next version.
-Optionally print during play the number of physics updates, frames per second, and a ballpark guess of allocated VRAM.
+Optionally print during play the number of physics updates, frames per second,
+and a ballpark guess of allocated VRAM.
0.8.5
-----
diff --git a/.SRCINFO b/.SRCINFO
index 5eff1434befc..0b4bd3aef46d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 26 19:23:41 UTC 2017
+# Thu Jan 4 23:32:45 UTC 2018
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.6
+ pkgver = 0.9.7
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -16,10 +16,12 @@ pkgbase = lix
depends = allegro
depends = enet
conflicts = lix-git
- source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.6
+ source = lix::git+https://github.com/SimonN/LixD.git#tag=v0.9.7
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
+ source = build_fix.patch
sha512sums = SKIP
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
+ sha512sums = 44fb9d70bd517ad6e3246840de1654c8c8ad6545536528ac1bcc34c64c11b30f0984c18e6a3d5a9f96b963f644ead586b85a5c0e8ebae80cf3e2a8408471e0a0
pkgname = lix
diff --git a/PKGBUILD b/PKGBUILD
index 1b48011fbaaf..36acc90036c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix
-pkgver=0.9.6
+pkgver=0.9.7
pkgrel=1
conflicts=("${pkgname}-git")
source=("${pkgname}::git+https://github.com/SimonN/LixD.git#tag=v${pkgver}"
- "${pkgname}-music-1.zip::http://www.lixgame.com/dow/lix-music.zip")
+ "${pkgname}-music-1.zip::http://www.lixgame.com/dow/lix-music.zip"
+ "build_fix.patch")
sha512sums=('SKIP'
- '37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425')
+ '37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425'
+ '44fb9d70bd517ad6e3246840de1654c8c8ad6545536528ac1bcc34c64c11b30f0984c18e6a3d5a9f96b963f644ead586b85a5c0e8ebae80cf3e2a8408471e0a0')
prepare()
{
@@ -16,10 +18,15 @@ prepare()
# generate .desktop-file
gendesk -n -f --categories "Game"
+
+ cd "${srcdir}/${pkgname}"
+
+ # this is needed until the next release
+ patch -p1 -i "${srcdir}/build_fix.patch"
}
_pkgname=${pkgname}
-# template start; name=lix; version=0.3;
+# template start; name=lix; version=0.4;
pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="http://www.lixgame.com/"
@@ -42,7 +49,7 @@ build()
dub add-local enumap-*/enumap
# force FHS compatibility with '-b releaseXDG'
- dub build -f -b releaseXDG --cache=local
+ dub build -f -b releaseXDG --cache=local || _r=$?
# remove local dependencies from search path so dub don't find them later again
dub remove-local allegro-*/allegro
@@ -50,6 +57,11 @@ build()
dub remove-local derelict-util-*/derelict-util
dub remove-local enumap-*/enumap
dub clean-caches
+
+ if [[ $_r != 0 ]] ; then
+ # dub failed so we also fail after we removed the local dependencies
+ return $_r
+ fi
}
package()
diff --git a/build_fix.patch b/build_fix.patch
new file mode 100644
index 000000000000..bbc1334d5a58
--- /dev/null
+++ b/build_fix.patch
@@ -0,0 +1,12 @@
+diff --git a/dub.json b/dub.json
+index fe833b4d..d63d615a 100644
+--- a/dub.json
++++ b/dub.json
+@@ -24,6 +24,7 @@
+ "allegro_primitives",
+ "allegro",
+ ],
++ "libs-linux": ["allegro-5"],
+ "sourceFiles-windows": ["src\\icon.res"],
+ "dflags-windows": ["-Jsrc\\icon.res"],
+ "lflags-windows": ["-L/subsystem:windows"],