summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2024-06-07 18:26:03 +0200
committerLucki2024-06-07 18:26:03 +0200
commit51ad7cb7acba0e94ad402a3151319e34a8b38d98 (patch)
tree5edf4b89a7b00ae276e9604a4fabeb9fe442dd6c
parent9d44769f76fe698e17316bd1c7169807a9a39b50 (diff)
downloadaur-51ad7cb7acba0e94ad402a3151319e34a8b38d98.tar.gz
upgpkg: lix 0.10.23-2
remove unnecessary roundabout
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 968dd19f8451..ea5aed1c5e97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
pkgver = 0.10.23
- pkgrel = 1
+ pkgrel = 2
url = https://www.lixgame.com/
changelog = .CHANGELOG
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index cf82c58b09ff..300cbe1f6fd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=lix
pkgver=0.10.23
-pkgrel=1
+pkgrel=2
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz"
"$pkgname-music-1.1.zip::https://www.lixgame.com/dow/lix-music.zip")
@@ -25,13 +25,9 @@ prepare() {
# Iterate thorugh the required packages and versions to fetch them in advance
# Read from dub.selections.json and print them as "package,version"
- for line in $(jq -r '.versions | keys[] as $k | "\($k),\(.[$k])"' <dub.selections.json); do
-
- # Split each dependency at the ','
- IFS=',' read -ra dep <<< "$line"
-
+ for line in $(jq -r '.versions | keys[] as $k | "\($k)@\(.[$k])"' <dub.selections.json); do
# Fetch each package at the required version
- dub fetch --cache=local "${dep[0]}@${dep[1]}"
+ dub fetch --cache=local "$line"
done
}