summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2022-03-29 23:01:40 +0200
committerLucki2022-03-29 23:01:40 +0200
commit7963511cb50c7344e3600f5a9313309bff48783f (patch)
treec2050ab9bed836bdacc99409edeb0725cdf84199
parentcb1b6907ef0fec08948a03c3596cc0ed8eb48696 (diff)
downloadaur-7963511cb50c7344e3600f5a9313309bff48783f.tar.gz
upstream release
-rw-r--r--.CHANGELOG38
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
3 files changed, 44 insertions, 5 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index d03634c1e1e7..7b498941c20e 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,38 @@
Version history
===============
+0.9.43
+------
+
+2022-03-29
+
+Fix server-side permutation bug: In 0.9.42, the server re-rolled the
+permutation of starting points for every player. This desynched the maps --
+unless you were only playing 2-player on perfectly symmetrical maps and never
+used directional force.
+
+Don't send up to 300 nullbytes on short chat packets, send only the necessary
+bytes. Keep max chat length at 300 UTF-8 code units.
+
+In the lobby, sort the list of players. First criterion: Players sort higher
+than observers. Second criterion: Red sorts higher than orange, yellow, ...
+Third criterion: Within each color, sort by player name. Ready/unready doesn't
+affect sorting. It's easier now to see which/how many colors are in use, but
+I'll leave open github issue #407: Color buttons in lobby, show current usage.
+
+Disable the expensive level-drawing unittest that also didn't clean up
+its file in ./export/.
+
+macOS: Rely on pkg-config according to Allegro's documentation here:
+https://github.com/liballeg/allegro5/blob/master/README_pkgconfig.txt
+Before, on macOS ARM64, ld didn't find the Allegro libs even with pkg-confic
+installed; see github issue #430.
+
+Remove obsolete build documentation ./doc/build/allegro5.txt and
+cross-reference more clearly between other files in ./doc/build/.
+
+
+
0.9.42
------
@@ -24,9 +56,15 @@ zero warnings again.
Refactored the server-side networking code. Rooms carry their own logic. This
will help in the future to support version restrictions per room.
+Fixed DMD 64-bit build on all operating systems by avoiding obscure usercode
+that crashes DMD.
+
Linux build notes: Added workaround for LDC running out of stack space. You
can raise the stack size in the current shell with: ulimit -s 16384
+Windows 32-bit build notes: Added DLL download for LDC-compatible 32-bit
+libraries.
+
Removed note from April 2020 in the readme about compilers before LDC 1.21;
compilers that old aren't prevalent anymore.
diff --git a/.SRCINFO b/.SRCINFO
index e5adcdb1be7c..be868b57e825 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.42
+ pkgver = 0.9.43
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,7 +14,7 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = liblphobos
- source = lix-0.9.42.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.42.tar.gz
+ source = lix-0.9.43.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.43.tar.gz
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
@@ -28,7 +28,7 @@ pkgbase = lix
source = lix-silly::git+https://gitlab.com/AntonMeep/silly.git#tag=v1.0.2
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.22
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = a1b0939c414c96cbc53e9fb081b95785da440c9ff09be4a2983aa6b9aa063cfe27ff2889d4c31f63700d8ccaa7c2888422d6bde40233f2f647b10c008c6aca6d
+ sha512sums = 694876861bbd988b34b9c2f796b05fbeca80e745de97d07d60b05dff8371f3fd4e25be20aa07d5c4e6a6aef5a58a383e66ad181aa1f8f38359a8307a934ff1a1
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
sha512sums = 375b1439d9398371a3f58a92bfc0901b86bd89140aae431c7d9405bd2fb36ebcdb22b2686fea72d88b23a4ab94b138b4d742d8fd2965d8ec0542d2f8f64ed0c2
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a22942bf87bf..6dd98d1a58ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# shellcheck disable=2034,2154
pkgname=lix
-pkgver=0.9.42
+pkgver=0.9.43
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz")
-sha512sums=('a1b0939c414c96cbc53e9fb081b95785da440c9ff09be4a2983aa6b9aa063cfe27ff2889d4c31f63700d8ccaa7c2888422d6bde40233f2f647b10c008c6aca6d')
+sha512sums=('694876861bbd988b34b9c2f796b05fbeca80e745de97d07d60b05dff8371f3fd4e25be20aa07d5c4e6a6aef5a58a383e66ad181aa1f8f38359a8307a934ff1a1')
_gitname=LixD
pkgdesc="An action-puzzle game inspired by Lemmings"
@@ -68,6 +68,7 @@ sha512sums+=( 'SKIP'
_build() {
_r=0
+ # 2022.02.26
# 15:22 <@SimonN> It's possible that it's already enough to raise the stack size in the current shell: ulimit -s 16384
# 15:22 <@SimonN> See also: https://github.com/ldc-developers/ldc/issues/3913
# 15:26 <@SimonN> Yes, very high chance that the following will fix/workaround: Execute "ulimit -s 16384" in the same shell that will then run dub. I.e., we double the stack size, assuming "ulimit -s" printed 8192 before; it does that for me in new shells.