summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2023-08-30 13:42:14 +0200
committerLucki2023-08-30 13:42:14 +0200
commit7faf1714604c32d40fd1bb2edcb9fb38d9f82f8f (patch)
tree50fb9f80168422443ecd9dcdd53f6b37af7f562b
parent5650ed1794168a6709f306117ecbe5a1ece15618 (diff)
downloadaur-7faf1714604c32d40fd1bb2edcb9fb38d9f82f8f.tar.gz
upgpkg: lix 0.10.15-1
upstream release
-rw-r--r--.CHANGELOG26
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
3 files changed, 31 insertions, 5 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 243c68476587..bf2eb1ea8ffc 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,32 @@
Version history
===============
+0.10.15
+
+2023-08-30
+
+Fix a performance bug: In insert mode (i.e., by default, when the tweaker was
+open), new assignments would always recompute all physics since the beginning,
+even if nothing needed recomputation. Now, we recompute only as necessary.
+
+Fix #448: Prevent tumblers from repeatedly crying "Ouch" when they're trapped
+in a permanent flinger.
+
+Add user option: Allow blurry zoom. It's on by default. If you deactivate
+this, you force Lix to use only crisp integer zoom factors (1x, 2x, 3x, ...)
+that won't always fit the level to the screen size.
+
+Re-label the tweaker's "<", ">" buttons with "−" and "+". Reason:
+These buttons move assignments to a different tick, not left or right.
+
+Narrow the tweaker to fit more level on the screen.
+
+Allow .mp3 in the music/ directory. This works out of the box on Windows.
+On Linux or Mac, you must build Allegro 5 with the MiniMP3 library to hear
+the .mp3 files that you put in music/.
+
+
+
0.10.14
-------
diff --git a/.SRCINFO b/.SRCINFO
index 77f83a9276ab..619d2cc65f21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.10.14
+ pkgver = 0.10.15
pkgrel = 1
url = https://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,7 +14,7 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = d-runtime
- source = lix-0.10.14.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.10.14.tar.gz
+ source = lix-0.10.15.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.10.15.tar.gz
source = lix-music-1.1.zip::https://www.lixgame.com/dow/lix-music.zip
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.6+5.2.0
source = lix-bolts::git+https://github.com/aliak00/bolts.git#tag=v1.3.1
@@ -25,7 +25,7 @@ pkgbase = lix
source = lix-sdlang-d::git+https://github.com/Abscissa/SDLang-D.git#tag=v0.10.6
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.22
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = 1c7634deb780be4a8939e21db558b5a6da46305eed979c5f590049029b60bda9dbbcb0bf5e92c33fbc2f795a4b02f74deeef334e7936615a28ac24d04dfdfe7b
+ sha512sums = 5c2e9825aa78bceed5e888fa1a382d47adb8f58b69d1b6beb18961fac50d1c541f25cd27f05b5d4d199fad2f693a371ad8066db41bd6822252ed4263d782c45d
sha512sums = 280fd25a479ac8dd24475b014234270a12ab34edca7fb2f7ce4b768259111b1e7626d3ba37ac13d810f0653d23d7c9f212776e94d2c0b31a0de580864771ce9f
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c4ae0ba17050..75ac4ad048a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# shellcheck disable=SC2034,SC2154
pkgname=lix
-pkgver=0.10.14
+pkgver=0.10.15
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz"
"$pkgname-music-1.1.zip::https://www.lixgame.com/dow/lix-music.zip")
-sha512sums=('1c7634deb780be4a8939e21db558b5a6da46305eed979c5f590049029b60bda9dbbcb0bf5e92c33fbc2f795a4b02f74deeef334e7936615a28ac24d04dfdfe7b'
+sha512sums=('5c2e9825aa78bceed5e888fa1a382d47adb8f58b69d1b6beb18961fac50d1c541f25cd27f05b5d4d199fad2f693a371ad8066db41bd6822252ed4263d782c45d'
'280fd25a479ac8dd24475b014234270a12ab34edca7fb2f7ce4b768259111b1e7626d3ba37ac13d810f0653d23d7c9f212776e94d2c0b31a0de580864771ce9f')
_gitname=LixD