summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2023-08-10 20:15:17 +0200
committerLucki2023-08-10 20:15:17 +0200
commita54ea509b46dc083548f7ac12b5ae60252d3d0eb (patch)
treeb74449362d06323955584f694ed26f5061d7774c
parent133584966475f37430c85591b80e752c83146e50 (diff)
downloadaur-a54ea509b46dc083548f7ac12b5ae60252d3d0eb.tar.gz
upgpkg: lix 0.10.13-1
upstream release
-rw-r--r--.CHANGELOG36
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
3 files changed, 43 insertions, 7 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 68242cdfa66d..a0128cc7dd7d 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,42 @@
Version history
===============
+0.10.13
+-------
+
+2023-08-08
+
+The tooltip for replaying (click to play) is now at the top of the screen,
+in the top-right corner. Hovering-sensitive toolips are still at the bottom.
+
+Rename Phyu (number of physics updates since the start of play) to Tick
+throughout UI and translations.
+
+Fix reading memory outside of array bounds during the option menu's sound
+previewing. All writes were inbounds, therefore I doubt that this bug has
+ever crashed anybody's Lix.
+
+Fix compilation errors with DMD 2.105.0.
+
+Upgrade the Allegro 5 D bindings to fix compiler warnings from DMD 2.104.0.
+
+Refactor the Walker skill to function without saving and resetting position
+and encounters, and to avoid unnecessary physics map reads. Replay
+verification runs 2 % faster now. All replays in the proof collection appear
+to pass with identical timings as before, that is sufficient proof to me that
+I didn't change physics.
+
+Align the lix' struct to 64-byte boundaries. Replay verification runs another
+1 % faster now.
+
+The physics map stores bytes, not 16-bit integers. Transpose the physics map
+to storing columns, not rows. This appers to neither improve nor worsen
+performance.
+
+Move code for the lix and for the skill hierarchy into src/physics/.
+
+
+
0.10.12
-------
diff --git a/.SRCINFO b/.SRCINFO
index 862aa0511acd..991c98d66788 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.10.12
+ pkgver = 0.10.13
pkgrel = 1
url = https://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,9 +14,9 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = d-runtime
- source = lix-0.10.12.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.10.12.tar.gz
+ source = lix-0.10.13.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.10.13.tar.gz
source = lix-music-1.1.zip::https://www.lixgame.com/dow/lix-music.zip
- source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
+ source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.6+5.2.0
source = lix-bolts::git+https://github.com/aliak00/bolts.git#tag=v1.3.1
source = lix-derelict-enet::git+https://github.com/DerelictOrg/DerelictENet.git#tag=v4.2.0
source = lix-derelict-util::git+https://github.com/DerelictOrg/DerelictUtil.git#tag=v3.0.0-beta.2
@@ -25,7 +25,7 @@ pkgbase = lix
source = lix-sdlang-d::git+https://github.com/Abscissa/SDLang-D.git#tag=v0.10.6
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.22
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = 1968969759ee24887acd88af9d6bd1b322d36b72aaa9657ccfcda5db35f63049f6e61975578842f72382858d0a65c706d011bc9844637409257466e4116f8e52
+ sha512sums = b6ae74578ee0ecc610723829812797a4fec9b3470a6787d1bab80d8255aed87712b492b2bb8012b26447a52cf5be9dc077e368f7394915ad903376c86a80735f
sha512sums = 280fd25a479ac8dd24475b014234270a12ab34edca7fb2f7ce4b768259111b1e7626d3ba37ac13d810f0653d23d7c9f212776e94d2c0b31a0de580864771ce9f
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7700cf9b4739..3eb982b2b0a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# shellcheck disable=SC2034,SC2154
pkgname=lix
-pkgver=0.10.12
+pkgver=0.10.13
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz"
"$pkgname-music-1.1.zip::https://www.lixgame.com/dow/lix-music.zip")
-sha512sums=('1968969759ee24887acd88af9d6bd1b322d36b72aaa9657ccfcda5db35f63049f6e61975578842f72382858d0a65c706d011bc9844637409257466e4116f8e52'
+sha512sums=('b6ae74578ee0ecc610723829812797a4fec9b3470a6787d1bab80d8255aed87712b492b2bb8012b26447a52cf5be9dc077e368f7394915ad903376c86a80735f'
'280fd25a479ac8dd24475b014234270a12ab34edca7fb2f7ce4b768259111b1e7626d3ba37ac13d810f0653d23d7c9f212776e94d2c0b31a0de580864771ce9f')
_gitname=LixD
@@ -19,7 +19,7 @@ url="https://www.lixgame.com/"
license=('custom:CC0')
depends=('allegro' 'enet' 'hicolor-icon-theme' 'd-runtime')
makedepends=('git' 'd-compiler' 'dub')
-_dubv=( "4.0.4+5.2.0" # allegro
+_dubv=( "4.0.6+5.2.0" # allegro
"1.3.1" # bolts
"4.2.0" # derelict-enet
"3.0.0-beta.2" # derelict-util