summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2021-06-27 23:54:01 +0200
committerLucki2021-06-27 23:54:01 +0200
commitb9b18ebc437d570127395cd9046a0be003d3ef25 (patch)
tree0ac08ff029858cf8bcad25e2e7336ada8396960d
parent6742990f3458ef9147f9878a600f94278ca76d78 (diff)
downloadaur-b9b18ebc437d570127395cd9046a0be003d3ef25.tar.gz
upgpkg: lix 0.9.38-1
upstream release
-rw-r--r--.CHANGELOG54
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD4
3 files changed, 59 insertions, 6 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 50bf032680fd..fabe0e83c842 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,60 @@
Version history
===============
+0.9.38
+------
+
+2021-06-27
+
+Windowed mode at 1280x720 is now the default on running Lix for the very first
+time. Before, the default was software fullscreen a.k.a. fullscreen window.
+
+Smaller widescreen resolutions such at 1280x720 that would barely fail to pick
+2x for the skill panel icons (instead of the tiny 1x) will get slightly higher
+panel to accomodate the better-looking 2x skill icons.
+
+Adjusted text vertical offset to vertically center text on buttons better at
+1280x720. 1280x800 is still okay, text is now slightly too high here. The text
+positioning is already full of hacks and compromises, anything better either
+needs more hacks or a clean do-over. I feel like a 90's website designer.
+
+The main menu preserves the background's aspect ratio. To fill a screen that
+is not 4:3, it crops the background's sides.
+
+Revenge of the Giant Crab (2p): Added decoration, walkers 10->30, overtime
+30->90 seconds.
+
+Fix #424: Always show the level title in the lobby under the graphical preview,
+even when we return from a netgame.
+
+Fix #423: De-duplicate the multiplayer level tree, as reported by Dullstar.
+I had extra copies of Along the Fabrics of Your Clothing in the 8p directory.
+
+Updated Allegro DLLs to Allegro 5.2.7.1. You can check what Lix usesat runtime
+with Lix's command-line argument: --allgero-version
+
+I build the 32-bit Windows release with LDC, not with DMD. LDC generates
+faster-running machine code, exactly what we want for a release version. Tell
+me in case you run into any problems. (64-bit Windows release has always been
+built with LDC and it still is.)
+
+During compilation, Lix prints target architecture, OS, and compiler.
+
+Fix deprecations for DMD 2.097.0: In the source code, the "body" keyword is
+finally deprecated. Converted the entire codebase to the "do" keyword in front
+of function bodies. Added "static import std.stdio;" to access std.stdio.File
+in Lix's file.filename.base.
+
+Documentation: src/icon/readme.txt has CRLF line endings, to be readable in
+Windows Notepad. (Documentation should have CRLF endings, code should have LF
+endings.) Removed note in the 32-bit DMD Windows build notes about NuGet libs,
+DMD 32-bit doesn't play well with them.
+
+The build documentation points to new archives (lix-dlls-libs-dmd32.zip, lix-dlls-libs-ldc32.zip, lix-dlls-libs-win64.zip) because the .lib files
+can be incompatible between compilers.
+
+
+
0.9.37
------
diff --git a/.SRCINFO b/.SRCINFO
index 49c776224642..42ce396e44f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.37
+ pkgver = 0.9.38
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,7 +14,7 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = liblphobos
- source = lix-0.9.37.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.37.tar.gz
+ source = lix-0.9.38.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.38.tar.gz
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
@@ -28,7 +28,7 @@ pkgbase = lix
source = lix-silly::git+https://gitlab.com/AntonMeep/silly.git#tag=v1.0.2
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.18
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = 8b8faa451010b36a461075e9f7c7117c0af7f06af422e2ac207efd1c98e814dc20b23a1dd16cb6994c86354a11aa0e99f355ede299e0a46455f914f2ddab0ea5
+ sha512sums = 1cd9025ad76e224eab0cef65b6d34bda9d186a99376c1e81c5252251f75d4d4f972328bca54b6807204eb2886a8b160462d7e92ae652d4dcae99d7be55463d06
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
sha512sums = 375b1439d9398371a3f58a92bfc0901b86bd89140aae431c7d9405bd2fb36ebcdb22b2686fea72d88b23a4ab94b138b4d742d8fd2965d8ec0542d2f8f64ed0c2
sha512sums = SKIP
@@ -44,4 +44,3 @@ pkgbase = lix
sha512sums = SKIP
pkgname = lix
-
diff --git a/PKGBUILD b/PKGBUILD
index 9242a2d2e788..f3531afc51ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# shellcheck disable=SC2034,2154,2148
pkgname=lix
-pkgver=0.9.37
+pkgver=0.9.38
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz")
-sha512sums=('8b8faa451010b36a461075e9f7c7117c0af7f06af422e2ac207efd1c98e814dc20b23a1dd16cb6994c86354a11aa0e99f355ede299e0a46455f914f2ddab0ea5')
+sha512sums=('1cd9025ad76e224eab0cef65b6d34bda9d186a99376c1e81c5252251f75d4d4f972328bca54b6807204eb2886a8b160462d7e92ae652d4dcae99d7be55463d06')
_gitname=LixD
pkgdesc="An action-puzzle game inspired by Lemmings"