summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2022-03-02 11:44:07 +0100
committerLucki2022-03-02 11:44:07 +0100
commitcb1b6907ef0fec08948a03c3596cc0ed8eb48696 (patch)
tree1eaffc7aa8a2ac68a4edc5a2642b9562545b1120
parentaa261b7fe63268dee0078d170c4209a3779f63ea (diff)
downloadaur-cb1b6907ef0fec08948a03c3596cc0ed8eb48696.tar.gz
upgpkg: lix 0.9.42-1
upstream release
-rw-r--r--.CHANGELOG31
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
3 files changed, 41 insertions, 5 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index b040f92e45ee..d03634c1e1e7 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,6 +1,37 @@
Version history
===============
+0.9.42
+------
+
+2022-02-25
+
+Don't focus the IP address entry field in the lobby when you select "connect
+to somebody else". The focusing led to a bug that is now fixed: The field
+would even be unhidden and focused whenever the lobby window reappeared after
+a game, when you were already connected and in a room.
+
+Alleviated enet versioning mismatch: derelict-enet offers D bindings only for
+enet 1.3.15, but the binaries of enet 1.3.16 or the current enet 1.3.17 have
+differently-sized struct ENetPeer. Now, the Lix server computes the struct
+size at runtime, allowing to run with all enet binaries >= 1.3.13.
+
+Fixed a theoretically possible, although unlikely, memory leak in networking.
+
+Fixed a linker warning about max!(int, int). Now, Lix's code itself generates
+zero warnings again.
+
+Refactored the server-side networking code. Rooms carry their own logic. This
+will help in the future to support version restrictions per room.
+
+Linux build notes: Added workaround for LDC running out of stack space. You
+can raise the stack size in the current shell with: ulimit -s 16384
+
+Removed note from April 2020 in the readme about compilers before LDC 1.21;
+compilers that old aren't prevalent anymore.
+
+
+
0.9.41
------
diff --git a/.SRCINFO b/.SRCINFO
index c8957787e72d..e5adcdb1be7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.41
+ pkgver = 0.9.42
pkgrel = 1
url = http://www.lixgame.com/
changelog = .CHANGELOG
@@ -14,7 +14,7 @@ pkgbase = lix
depends = enet
depends = hicolor-icon-theme
depends = liblphobos
- source = lix-0.9.41.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.41.tar.gz
+ source = lix-0.9.42.src.tar.gz::https://github.com/SimonN/LixD/archive/v0.9.42.tar.gz
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
source = lix-allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.4+5.2.0
@@ -28,7 +28,7 @@ pkgbase = lix
source = lix-silly::git+https://gitlab.com/AntonMeep/silly.git#tag=v1.0.2
source = lix-taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git#tag=v0.11.22
source = lix-unit-threaded::git+https://github.com/atilaneves/unit-threaded.git#tag=v0.7.55
- sha512sums = bfe3eff094a88a03f64ff10bdc24ecfce99201273ebe54c022131290aa5814b477602d1eb3dabc3e730353808031a687f276a8c5a4aaaaff0ecaeccec76b512e
+ sha512sums = a1b0939c414c96cbc53e9fb081b95785da440c9ff09be4a2983aa6b9aa063cfe27ff2889d4c31f63700d8ccaa7c2888422d6bde40233f2f647b10c008c6aca6d
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
sha512sums = 375b1439d9398371a3f58a92bfc0901b86bd89140aae431c7d9405bd2fb36ebcdb22b2686fea72d88b23a4ab94b138b4d742d8fd2965d8ec0542d2f8f64ed0c2
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 532165c98675..a22942bf87bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# shellcheck disable=2034,2154
pkgname=lix
-pkgver=0.9.41
+pkgver=0.9.42
pkgrel=1
changelog=.CHANGELOG
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/SimonN/LixD/archive/v$pkgver.tar.gz")
-sha512sums=('bfe3eff094a88a03f64ff10bdc24ecfce99201273ebe54c022131290aa5814b477602d1eb3dabc3e730353808031a687f276a8c5a4aaaaff0ecaeccec76b512e')
+sha512sums=('a1b0939c414c96cbc53e9fb081b95785da440c9ff09be4a2983aa6b9aa063cfe27ff2889d4c31f63700d8ccaa7c2888422d6bde40233f2f647b10c008c6aca6d')
_gitname=LixD
pkgdesc="An action-puzzle game inspired by Lemmings"
@@ -68,6 +68,11 @@ sha512sums+=( 'SKIP'
_build() {
_r=0
+ # 15:22 <@SimonN> It's possible that it's already enough to raise the stack size in the current shell: ulimit -s 16384
+ # 15:22 <@SimonN> See also: https://github.com/ldc-developers/ldc/issues/3913
+ # 15:26 <@SimonN> Yes, very high chance that the following will fix/workaround: Execute "ulimit -s 16384" in the same shell that will then run dub. I.e., we double the stack size, assuming "ulimit -s" printed 8192 before; it does that for me in new shells.
+ ulimit -s 16384
+
# add local dependencies to search path
dub add-path "$srcdir"