summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Yvan Boutet Livoff2018-03-07 15:53:39 +0100
committerEmile Yvan Boutet Livoff2018-03-07 15:53:39 +0100
commit552b6e245d7fc8292df5b166a89797670269c8e2 (patch)
tree358a8e5ce2cd6850eae640eef1327eb4e7c53cba
downloadaur-552b6e245d7fc8292df5b166a89797670269c8e2.tar.gz
inital commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2104d4daae49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lix-ereader
+ pkgdesc = A proprietary e-reader
+ pkgver = 1.0.15
+ pkgrel = 1
+ url = https://www.lix.com/
+ arch = x86_64
+ license = unknown
+ depends = alsa-lib
+ depends = libxss
+ depends = gconf
+ depends = gtk2
+ depends = nss
+ depends = libxtst
+ source = https://download.lix.com/linux/latest
+ md5sums = 2df5cc1ecc8830edd941032e6e4b53b0
+
+pkgname = lix-ereader
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f11fcef32183
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Emile Boutet-Livoff <emilelivoff@gmail.com>
+
+pkgname=lix-ereader
+pkgver=1.0.15
+pkgrel=1
+pkgdesc="A proprietary e-reader"
+arch=('x86_64')
+url='https://www.lix.com/'
+license=('unknown')
+#Might depend on libappindicator-gtk2, gconf, libindicator-gtk2, libnotify
+#It has it's own libnode.so and libffmpeg.so
+depends=('alsa-lib' 'libxss' 'gconf' 'gtk2' 'nss' 'libxtst')
+source=("https://download.lix.com/linux/latest")
+md5sums=("2df5cc1ecc8830edd941032e6e4b53b0")
+
+prepare() {
+ cd "${srcdir}"
+
+ # Remove libraries, they are dependencies
+ rm -r usr/lib
+
+ # Desktop Entry
+ mkdir -p usr/share/applications
+ mv lix.desktop usr/share/applications
+
+ # Move the main chunk of it into opt
+ mkdir -p opt/lix
+ mv usr/bin/* opt/lix
+
+ # Add a symlink for the executable
+ ln -s /opt/lix/lix usr/bin/lix
+
+ # Make the usr/share/icons have the world executable bit set
+ chmod -R a+xr usr/share/icons
+}
+
+package() {
+ cd "${srcdir}"
+ cp -rp usr "${pkgdir}/usr"
+ cp -rp opt "${pkgdir}/opt"
+} \ No newline at end of file