summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Yvan Boutet Livoff2018-03-08 10:19:53 +0100
committerEmile Yvan Boutet Livoff2018-03-08 10:19:53 +0100
commit903611fe2eb195772f803497f6be945c66af1c6e (patch)
tree39f9188cb3989e2ac3d65d118737f8dd2d1ab5ee
parent552b6e245d7fc8292df5b166a89797670269c8e2 (diff)
downloadaur-903611fe2eb195772f803497f6be945c66af1c6e.tar.gz
Add .gitignore and fix space/tabs in PKGBUILD
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
2 files changed, 20 insertions, 16 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index f11fcef32183..a2b65d4416e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,28 +14,28 @@ source=("https://download.lix.com/linux/latest")
md5sums=("2df5cc1ecc8830edd941032e6e4b53b0")
prepare() {
- cd "${srcdir}"
+ cd "${srcdir}"
- # Remove libraries, they are dependencies
- rm -r usr/lib
+ # Remove libraries, they are dependencies
+ rm -r usr/lib
- # Desktop Entry
- mkdir -p usr/share/applications
- mv lix.desktop usr/share/applications
+ # Desktop Entry
+ mkdir -p usr/share/applications
+ mv lix.desktop usr/share/applications
- # Move the main chunk of it into opt
- mkdir -p opt/lix
- mv usr/bin/* opt/lix
+ # Move the main chunk of it into opt
+ mkdir -p opt/lix
+ mv usr/bin/* opt/lix
- # Add a symlink for the executable
- ln -s /opt/lix/lix usr/bin/lix
+ # Add a symlink for the executable
+ ln -s /opt/lix/lix usr/bin/lix
- # Make the usr/share/icons have the world executable bit set
- chmod -R a+xr usr/share/icons
+ # Make the usr/share/icons have the world executable bit set
+ chmod -R a+xr usr/share/icons
}
package() {
- cd "${srcdir}"
- cp -rp usr "${pkgdir}/usr"
+ cd "${srcdir}"
+ cp -rp usr "${pkgdir}/usr"
cp -rp opt "${pkgdir}/opt"
-} \ No newline at end of file
+}