summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2018-10-15 15:55:36 +0200
committerLucki2018-10-15 15:55:36 +0200
commit09abf7315dbf3cbd72a7d48503c3f1456ee9b524 (patch)
tree15618f6bdb8b71a34e41f2bc4870fcaec1f72215
parentbe0f0dce10a10e86fa8b8a9f485cfca5f99f24a3 (diff)
downloadaur-09abf7315dbf3cbd72a7d48503c3f1456ee9b524.tar.gz
Add missing dependencies
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD63
2 files changed, 47 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 861c229dbbb0..fa12b6ed1e42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix-git
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.19.r1536359906.8af2dfb3
+ pkgver = 0.9.20.r1539602759.ada5c09f
pkgrel = 1
url = http://www.lixgame.com/
arch = i686
@@ -17,13 +17,16 @@ pkgbase = lix-git
source = lix::git+https://github.com/SimonN/lix-unstable.git
source = lix-music-1.zip::http://www.lixgame.com/dow/lix-music.zip
source = lix.desktop
- source = allegro::git+https://github.com/SiegeLord/DAllegro5.git#tag=v4.0.3+5.2.0
+ source = allegro::git+https://github.com/SiegeLord/DAllegro5.git
source = bolts::git+https://github.com/aliak00/bolts.git#tag=v0.7.1
source = derelict-enet::git+https://github.com/DerelictOrg/DerelictENet.git#tag=v2.0.0
source = derelict-util::git+https://github.com/DerelictOrg/DerelictUtil.git#tag=v2.1.0
- source = enumap::git+https://github.com/rcorre/enumap.git#tag=v0.4.2
+ source = enumap::git+https://github.com/rcorre/enumap.git
source = optional::git+https://github.com/aliak00/optional.git#tag=v0.6.3
- source = silly::git+https://github.com/ohdatboi/silly.git#tag=v0.7.0
+ source = silly::git+https://github.com/ohdatboi/silly.git
+ source = sdlang-d::git+https://github.com/Abscissa/SDLang-D.git
+ source = taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git
+ source = unit-threaded::git+https://github.com/atilaneves/unit-threaded.git
sha512sums = SKIP
sha512sums = 37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425
sha512sums = 52d49562cd9be4eec76b464153af1cce2211fdbd6113a6a60df042f7e8f7e6a8f1942df883dfaaa6c1bbfea004c4154d884dfa767e25fa3fadf9c58be1103fe6
@@ -34,6 +37,9 @@ pkgbase = lix-git
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = lix-git
diff --git a/PKGBUILD b/PKGBUILD
index 485d19e734b8..7f1a4f3726fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix-git
-pkgver=0.9.20.r1537722993.ca86cbc0
+pkgver=0.9.20.r1539602759.ada5c09f
pkgrel=1
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -25,7 +25,7 @@ pkgver()
}
_pkgname=${pkgname%-git}
-# template start; name=lix; version=0.9;
+# template start; name=lix; version=1.0;
pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="http://www.lixgame.com/"
@@ -38,8 +38,12 @@ _dub_versions=( '4.0.3+5.2.0' # Allegro
'2.1.0' # Derelict-Util
'0.4.2' # Enumap
'0.6.3' # Optional
- '0.7.1') # Silly
-
+ '0.7.1' # Silly
+ '0.10.4' # SDLang-D
+ '' # taggedalgebraic
+ '' # unit-threaded
+ )
+
# let makepkg handle dub packages
# https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git_Submodules
source+=( "${_pkgname}-music-1.zip::http://www.lixgame.com/dow/lix-music.zip"
@@ -51,7 +55,10 @@ source+=( "${_pkgname}-music-1.zip::http://www.lixgame.com/dow/lix-music.zip"
"enumap::git+https://github.com/rcorre/enumap.git" #tag=v${_dub_versions[4]}"
"optional::git+https://github.com/aliak00/optional.git#tag=v${_dub_versions[5]}"
"silly::git+https://github.com/ohdatboi/silly.git" #tag=v${_dub_versions[6]}"
- )
+ "sdlang-d::git+https://github.com/Abscissa/SDLang-D.git" #tag=v${_dub_versions[7]}"
+ "taggedalgebraic::git+https://github.com/s-ludwig/taggedalgebraic.git" #tag=v${_dub_versions[8]}
+ "unit-threaded::git+https://github.com/atilaneves/unit-threaded.git" #tag=v${_dub_versions[9]}
+ )
sha512sums+=( '37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0c7f63c3f3599a47bb4ef52f5bfd14e034010de0ac2aec5a9c0c83eaf0b89425'
'52d49562cd9be4eec76b464153af1cce2211fdbd6113a6a60df042f7e8f7e6a8f1942df883dfaaa6c1bbfea004c4154d884dfa767e25fa3fadf9c58be1103fe6'
'SKIP'
@@ -60,28 +67,32 @@ sha512sums+=( '37349c98b739ea43c25137dd03865f1c9c41eec91e5edc109afd9d50ce3871bd0
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ )
build()
{
cd "${srcdir}/${_pkgname}" || exit
_r=0
-
+
# add local dependencies to search path
dub add-path "${srcdir}"
-
+
# force FHS compatibility with '-b releaseXDG'
# ensure with --cache=local dub stays outside the users home directory
dub build -f -b releaseXDG --cache=local || _r="${?}"
-
+
# remove local dependencies from search path so dub won't find them
# later again
dub remove-path "${srcdir}"
-
- # removes any cached metadata like the list of available packages
+
+ # removes any cached metadata like the list of available packages
# and their latest version
dub clean-caches
-
+
if [[ "${_r}" != 0 ]]
then
# dub failed so we also fail after we removed the local dependencies
@@ -93,22 +104,22 @@ check()
{
cd "${srcdir}/${_pkgname}" || exit
_r=0
-
+
# add local dependencies to search path
dub add-path "${srcdir}"
-
+
# run test suite
# ensure with --cache=local dub stays outside the users home directory
dub test --cache=local || _r="${?}"
-
+
# remove local dependencies from search path so dub won't find them
# later again
dub remove-path "${srcdir}"
-
- # removes any cached metadata like the list of available packages
+
+ # removes any cached metadata like the list of available packages
# and their latest version
dub clean-caches
-
+
if [[ "${_r}" != 0 ]]
then
# dub failed so we also fail after we removed the local dependencies
@@ -119,41 +130,41 @@ check()
package()
{
cd "${srcdir}" || exit
-
+
# install application entry
install -Dm644 \
`# SRCFILE:` \
"${_pkgname}.desktop" \
`# DSTFILE:` \
"${pkgdir}/usr/share/applications/${_pkgname}.desktop"
-
+
cd "${_pkgname}" || exit
-
+
# install application entry icon
install -Dm644 \
`# SRCFILE:` \
"data/images/${_pkgname}_logo.svg" \
`# DSTFILE:` \
"${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.svg"
-
+
# install license text
install -Dm644 \
`# SRCFILE:` \
"doc/copying.txt" \
`# DSTFILE:` \
"${pkgdir}/usr/share/licenses/${_pkgname}/COPYING"
-
+
# install binary
install -Dm755 \
`# SRCFILE:` \
"bin/${_pkgname}" \
`# DSTFILE:` \
"${pkgdir}/usr/bin/${_pkgname}"
-
+
# remove unimportant files
# https://raw.githubusercontent.com/SimonN/LixD/master/doc/build/package.txt
rm -r "${srcdir}/${_pkgname}/doc/build"
-
+
# https://lists.archlinux.org/pipermail/aur-general/2011-November/016777.html
# make directories
mkdir -p \
@@ -166,7 +177,7 @@ package()
"doc/." \
`# DSTDIR:` \
"${pkgdir}/usr/share/doc/${_pkgname}/"
-
+
# copy game files
cp -dpr --no-preserve=ownership \
`# SRCDIRS:` \