summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2017-09-16 20:23:32 +0200
committerLucki2017-09-16 20:23:32 +0200
commit187d026f30c628847afc03f91cde5a46c9bdcd49 (patch)
treee968bd28c37d55877730f06200e62e41c4b15f03
parent8633ae892f95008d9e2f09f5800d9c01fc8288c5 (diff)
downloadaur-187d026f30c628847afc03f91cde5a46c9bdcd49.tar.gz
Make use of tags…
…and move dub add-local to build() so if prepare() fails the packages aren't added to dubs internal list.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43e76939e44b..8013760f88f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Sep 9 11:18:25 UTC 2017
+# Sat Sep 16 18:20:47 UTC 2017
pkgbase = lix-git
pkgdesc = An action-puzzle game inspired by Lemmings
pkgver = r973.a2b7c3f
- pkgrel = 1
+ pkgrel = 2
url = http://www.lixgame.com/
changelog = .CHANGELOG
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 4430f8cfbdbc..30960bb813ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lix-git
pkgver=r973.a2b7c3f
-pkgrel=1
+pkgrel=2
pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="http://www.lixgame.com/"
@@ -19,9 +19,10 @@ sha512sums=('SKIP')
pkgver()
{
# https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git
- cd "${srcdir}/${pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ cd "${pkgname%-git}"
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
@@ -34,11 +35,14 @@ prepare()
gendesk -n -f --categories "Game"
# update .CHANGELOG
- git -C "${srcdir}/${pkgname%-git}" log --graph -10 > "${startdir}/.CHANGELOG"
-
- cd "${pkgname%-git}"
+ git -C "${srcdir}/${pkgname%-git}" log --graph -10 > "${startdir}/.CHANGELOG"
+}
+
+build()
+{
+ cd "${srcdir}/${pkgname%-git}"
- # force an upgrade of the dependencies to the local folder, without --cache=lokal they get added to the users home directory
+ # force an upgrade of the dependencies to the local folder, without --cache=local they get added to the users home directory
dub upgrade --cache=local
# add local dependencies to search path
@@ -46,11 +50,6 @@ prepare()
dub add-local derelict-enet-*/derelict-enet
dub add-local derelict-util-*/derelict-util
dub add-local enumap-*/enumap
-}
-
-build()
-{
- cd "${srcdir}/${pkgname%-git}"
# force FHS compatibility with '-b releaseXDG'
dub build -b releaseXDG --cache=local