summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2019-01-03 19:58:54 +0100
committerLucki2019-01-03 19:58:54 +0100
commitcc04b7cef05ee6a4bc4954f30d0571b9b54c36a0 (patch)
treec6dad31d1bf50deab301cdc9ca021b0441002216
parent9e4a95d02ad11f8da817211c5b1757d33c804568 (diff)
downloadaur-cc04b7cef05ee6a4bc4954f30d0571b9b54c36a0.tar.gz
Build with ldc since that's recommended
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD44
2 files changed, 18 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f28fb27c29a..5f129c7e8caf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = lix-git
pkgdesc = An action-puzzle game inspired by Lemmings
- pkgver = 0.9.23.r1544388479.29585ea7
+ pkgver = 0.9.24.r1546535491.5a566b5a
pkgrel = 1
url = http://www.lixgame.com/
arch = i686
arch = x86_64
license = custom:CC0
makedepends = git
- makedepends = dmd
+ makedepends = ldc
makedepends = dub
depends = allegro
depends = enet
depends = hicolor-icon-theme
+ depends = liblphobos
provides = lix
conflicts = lix
source = lix::git+https://github.com/SimonN/lix-unstable.git
diff --git a/PKGBUILD b/PKGBUILD
index ba26a64c161e..eeb866f88be2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Reinke <mindless2112 gmail com>
pkgname=lix-git
-pkgver=0.9.23.r1544388479.29585ea7
+pkgver=0.9.24.r1546535491.5a566b5a
pkgrel=1
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -25,13 +25,13 @@ pkgver()
}
_pkgname=${pkgname%-git}
-# template start; name=lix; version=1.3;
+# template start; name=lix; version=1.4;
pkgdesc="An action-puzzle game inspired by Lemmings"
arch=('i686' 'x86_64')
url="http://www.lixgame.com/"
license=('custom:CC0')
-depends=('allegro' 'enet' 'hicolor-icon-theme')
-makedepends=('git' 'dmd' 'dub')
+depends=('allegro' 'enet' 'hicolor-icon-theme' 'liblphobos')
+makedepends=('git' 'ldc' 'dub')
_dubv=( "4.0.4+5.2.0" # allegro
"0.7.1" # bolts
"4.1.0" # derelict-enet
@@ -79,7 +79,7 @@ sha512sums+=( 'SKIP'
'SKIP'
)
-build()
+_build()
{
cd "${srcdir}/${_pkgname}" || exit
_r=0
@@ -87,9 +87,8 @@ build()
# add local dependencies to search path
dub add-path "${srcdir}"
- # force FHS compatibility with '-b releaseXDG'
# ensure with --cache=local dub stays outside the users home directory
- dub build -f -b releaseXDG --cache=local || _r="${?}"
+ dub $@ --cache=local || _r="$?"
# remove local dependencies from search path so dub won't find them
# later again
@@ -106,31 +105,18 @@ build()
fi
}
-check()
+build()
{
cd "${srcdir}/${_pkgname}" || exit
- _r=0
-
- # add local dependencies to search path
- dub add-path "${srcdir}"
-
- # run test suite
- # ensure with --cache=local dub stays outside the users home directory
- dub test --cache=local || _r="${?}"
-
- # remove local dependencies from search path so dub won't find them
- # later again
- dub remove-path "${srcdir}"
- # removes any cached metadata like the list of available packages
- # and their latest version
- dub clean-caches
+ # force FHS compatibility with 'releaseXDG'
+ _build build --force --build=releaseXDG
+}
- if [[ "${_r}" != 0 ]]
- then
- # dub failed so we also fail after we removed the local dependencies
- return "${_r}"
- fi
+check()
+{
+ cd "${srcdir}/${_pkgname}" || exit
+ _build test --parallel
}
package()
@@ -165,7 +151,7 @@ package()
`# SRCFILE:` \
"doc/lix.6" \
`# DSTFILE:` \
- "${pkgdir}/usr/share/man/man6/lix.6.gz"
+ "${pkgdir}/usr/share/man/man6/lix.6"
# install binary
install -Dm755 \