summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Burrett2018-12-06 21:39:54 +0000
committerNick Burrett2018-12-06 21:39:54 +0000
commitd6a9f4db21474fceb0c7bdf2046c1d326459f3ba (patch)
tree17e1034ea661eab1164076cd8e37929150cb9492
parenta22e51e9f8beb539bf7bcb500e91e9553209e53e (diff)
downloadaur-lizardfs.tar.gz
- Fix build error caused by missing decl for makedev()
- Change fuse to fuse2 dependency. fuse3 isn't supported until the 3.13 release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--iostat.h.patch10
3 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86bc8411d441..8959a1c08c04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jan 27 09:52:55 UTC 2018
+# Thu Dec 6 21:37:36 UTC 2018
pkgbase = lizardfs
pkgdesc = LizardFS is a highly reliable, scalable and efficient distributed file system. It spreads data over a number of physical servers, making it visible to an end user as a single file system.
pkgver = 3.12.0
- pkgrel = 2
+ pkgrel = 3
url = http://lizardfs.com
install = lizardfs.install
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = lizardfs
depends = asciidoc
depends = boost
depends = zlib
- depends = fuse
+ depends = fuse2
depends = python2
depends = bash
depends = cmake
@@ -23,8 +23,10 @@ pkgbase = lizardfs
conflicts = mfs-client
source = http://github.com/lizardfs/lizardfs/archive/v3.12.0.tar.gz
source = cmath.patch
+ source = iostat.h.patch
sha256sums = d21220dc7542539b48d5bff7abe047a8c6bdbab19cb03579f88f146dee3ec5f6
sha256sums = fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c
+ sha256sums = ff4fb9bad5be91fa9d8214a57c782586e6232793cfc54503e1678519fd242984
pkgname = lizardfs
diff --git a/PKGBUILD b/PKGBUILD
index 5a3e8c52e071..7d11ba1e1119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
# lizardfs is a fork of moosefs and as such is a replacement for it.
pkgname=lizardfs
pkgver=3.12.0
-pkgrel=2
+pkgrel=3
pkgdesc='LizardFS is a highly reliable, scalable and efficient distributed file system. It spreads data over a number of physical servers, making it visible to an end user as a single file system.'
url='http://lizardfs.com'
conflicts=('moosefs' 'mfs-master' 'mfs-chunkserver' 'mfs-client')
arch=('x86_64' 'i686')
license=('GPL3')
-depends=('asciidoc' 'boost' 'zlib' 'fuse' 'python2' 'bash' 'cmake' 'unzip')
+depends=('asciidoc' 'boost' 'zlib' 'fuse2' 'python2' 'bash' 'cmake' 'unzip')
install="$pkgname.install"
source=("http://github.com/lizardfs/lizardfs/archive/v${pkgver}.tar.gz"
- "cmath.patch")
+ "cmath.patch"
+ "iostat.h.patch")
sha256sums=('d21220dc7542539b48d5bff7abe047a8c6bdbab19cb03579f88f146dee3ec5f6'
- 'fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c')
+ 'fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c'
+ 'ff4fb9bad5be91fa9d8214a57c782586e6232793cfc54503e1678519fd242984')
prepare() {
cd "lizardfs-${pkgver%_*}"
patch -Np1 -i $srcdir/cmath.patch
+ patch -Np1 -i $srcdir/iostat.h.patch
}
build() {
diff --git a/iostat.h.patch b/iostat.h.patch
new file mode 100644
index 000000000000..7ac70fa95d1e
--- /dev/null
+++ b/iostat.h.patch
@@ -0,0 +1,10 @@
+--- lizardfs-3.12.0/src/chunkserver/iostat.h.orig 2018-12-06 21:07:22.147629984 +0000
++++ lizardfs-3.12.0/src/chunkserver/iostat.h 2018-12-06 21:07:41.183716453 +0000
+@@ -44,6 +44,7 @@
+ #else
+ #include <cstdio>
+ #include <ctime>
++#include <sys/sysmacros.h>
+ #include <sys/vfs.h>
+
+ class IoStat {