summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Burrett2016-10-21 18:12:11 +0100
committerNick Burrett2016-10-21 18:12:11 +0100
commit7dee44f346f49499ae1048f1c7035edc8afb3d44 (patch)
tree46caa04ee7a0b3af35fee3cf618e1d451dbffedc
parent807155197b1155efcb6e905182e8e4f470b0d797 (diff)
downloadaur-7dee44f346f49499ae1048f1c7035edc8afb3d44.tar.gz
- Version 3.10.4
- cgiserv patches are no longer required.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
-rw-r--r--cgiserv.patch8
-rw-r--r--lizardfs-cgiservice.patch8
4 files changed, 10 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aed04db55895..f7e0429fd232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 18 15:46:05 UTC 2016
+# Fri Oct 21 17:11:52 UTC 2016
pkgbase = lizardfs
pkgdesc = LizardFS is a highly reliable, scalable and efficient distributed file system. It spreads data over a number of physical servers, making it visible to an end user as a single file system.
- pkgver = 3.10.2
- pkgrel = 2
+ pkgver = 3.10.4
+ pkgrel = 1
url = http://lizardfs.com
install = lizardfs.install
arch = x86_64
@@ -16,14 +16,10 @@ pkgbase = lizardfs
depends = python2
depends = bash
depends = cmake
- source = http://github.com/lizardfs/lizardfs/archive/v3.10.2.tar.gz
+ source = http://github.com/lizardfs/lizardfs/archive/v3.10.4.tar.gz
source = cmath.patch
- source = lizardfs-cgiservice.patch
- source = cgiserv.patch
- sha256sums = 972cc6c46629ebdf7b85f34c782583bb37be46de99dcf299fc92b355aa3a19cc
+ sha256sums = 3c4b954bb91b376d3099d4e23296044ce41d5bd07da220ab090889ab28bf6b71
sha256sums = fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c
- sha256sums = b4ec6781cc7561ac67dcc26e3ae93ca5780b89fcbc4750fd540cff8202121a05
- sha256sums = 7c0ad5c42b8f1bea848db1dcda41d20dd7bf9b802467b7dfc376788dd82bb6d4
pkgname = lizardfs
diff --git a/PKGBUILD b/PKGBUILD
index b51c4ab5a944..1f4a10abf0a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nick Burrett <nick@sqrt.co.uk>
# lizardfs is a fork of moosefs and as such is a replacement for it.
pkgname=lizardfs
-pkgver=3.10.2
-pkgrel=2
+pkgver=3.10.4
+pkgrel=1
pkgdesc='LizardFS is a highly reliable, scalable and efficient distributed file system. It spreads data over a number of physical servers, making it visible to an end user as a single file system.'
url='http://lizardfs.com'
conflics=('moosefs' 'mfs-master' 'mfs-chunkserver' 'mfs-client')
@@ -11,19 +11,13 @@ license=('GPL3')
depends=('asciidoc' 'boost' 'zlib' 'fuse' 'python2' 'bash' 'cmake')
install="$pkgname.install"
source=("http://github.com/lizardfs/lizardfs/archive/v${pkgver}.tar.gz"
- "cmath.patch"
- "lizardfs-cgiservice.patch"
- "cgiserv.patch")
-sha256sums=('972cc6c46629ebdf7b85f34c782583bb37be46de99dcf299fc92b355aa3a19cc'
- 'fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c'
- 'b4ec6781cc7561ac67dcc26e3ae93ca5780b89fcbc4750fd540cff8202121a05'
- '7c0ad5c42b8f1bea848db1dcda41d20dd7bf9b802467b7dfc376788dd82bb6d4')
+ "cmath.patch")
+sha256sums=('3c4b954bb91b376d3099d4e23296044ce41d5bd07da220ab090889ab28bf6b71'
+ 'fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c')
prepare() {
cd "lizardfs-${pkgver%_*}"
patch -Np1 -i $srcdir/cmath.patch
- patch -Np1 -i $srcdir/lizardfs-cgiservice.patch
- patch -Np1 -i $srcdir/cgiserv.patch
}
build() {
diff --git a/cgiserv.patch b/cgiserv.patch
deleted file mode 100644
index db499bd3f8c0..000000000000
--- a/cgiserv.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- lizardfs-3.10.2/src/cgi/cgiserv.py.in.orig 2016-09-18 16:43:05.075283198 +0100
-+++ lizardfs-3.10.2/src/cgi/cgiserv.py.in 2016-09-18 16:43:11.145096379 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- import fcntl
- import errno
- import posix
diff --git a/lizardfs-cgiservice.patch b/lizardfs-cgiservice.patch
deleted file mode 100644
index 71475eee7dd2..000000000000
--- a/lizardfs-cgiservice.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- lizardfs-3.10.2/src/cgi/lizardfs-cgiserver.py.in.orig 2016-09-18 16:35:35.542456837 +0100
-+++ lizardfs-3.10.2/src/cgi/lizardfs-cgiserver.py.in 2016-09-18 16:35:49.685354565 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- # vim: noexpandtab shiftwidth=4 softtabstop=4 tabstop=4
-
- import fcntl