summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Burrett2016-09-07 10:10:17 +0100
committerNick Burrett2016-09-07 10:18:18 +0100
commitcb1c541b412ca0afc9a9324aa0917410476488ce (patch)
treec78b28fe3e95ff5cd95231d9995362331e4baf39
parent0d148cb8b5b648e3c28d651d6f20939a4beb05c8 (diff)
downloadaur-cb1c541b412ca0afc9a9324aa0917410476488ce.tar.gz
Upgrade from 3.9.4 to 3.10.0. The cmake patch can be dropped.
One file needs <cmath>
-rw-r--r--PKGBUILD13
-rw-r--r--cmake.patch7
-rw-r--r--cmath.patch10
3 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc432cf271f8..7dbdf799302e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nick Burrett <nick@sqrt.co.uk>
# lizardfs is a fork of moosefs and as such is a replacement for it.
pkgname=lizardfs
-pkgver=3.9.4
-pkgrel=2
+pkgver=3.10.0
+pkgrel=1
pkgdesc='LizardFS is a highly reliable, scalable and efficient distributed file system. It spreads data over a number of physical servers, making it visible to an end user as a single file system.'
url='http://lizardfs.com'
conflics=('moosefs' 'mfs-master' 'mfs-chunkserver' 'mfs-client')
@@ -11,16 +11,15 @@ license=('GPL3')
depends=('asciidoc' 'boost' 'zlib' 'fuse' 'python2' 'bash' 'cmake')
install="$pkgname.install"
source=("http://github.com/lizardfs/lizardfs/archive/v.${pkgver}.tar.gz"
- "cmake.patch")
-sha256sums=('ece4e3f3433f6a26edf09b9f1ab0e867dd5e558f8966407792a38cb91ee91585'
- 'b233e631aed57fac8fc28003e390055582e45743e48c7ffe24af3a559b70e154')
+ "cmath.patch")
+sha256sums=('6040c1accc296b9d9d0d00e8c595d51f88c269d385ddedc18b98d46c5d21dcc2'
+ 'fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c')
prepare() {
cd "lizardfs-v.${pkgver%_*}"
- patch -Np1 -i $srcdir/cmake.patch
+ patch -Np1 -i $srcdir/cmath.patch
}
-
build() {
cd "lizardfs-v.${pkgver%_*}"
./configure
diff --git a/cmake.patch b/cmake.patch
index 61ad508f4637..e69de29bb2d1 100644
--- a/cmake.patch
+++ b/cmake.patch
@@ -1,7 +0,0 @@
---- lizardfs-3.9.2/CheckIncludes.cmake.orig 2015-11-24 10:26:48.425365487 +0000
-+++ lizardfs-3.9.2/CheckIncludes.cmake 2015-11-24 10:27:03.269328267 +0000
-@@ -1,3 +1,4 @@
-+include(CheckIncludeFiles)
- function(check_includes INCLUDES)
- set(INCLUDE_MISSING FALSE)
- foreach(INCLUDE_FILE ${INCLUDES})
diff --git a/cmath.patch b/cmath.patch
new file mode 100644
index 000000000000..d0d6a610646d
--- /dev/null
+++ b/cmath.patch
@@ -0,0 +1,10 @@
+--- lizardfs-v.3.10.0/src/common/slice_read_planner.cc.orig 2016-09-07 10:05:08.436831333 +0100
++++ lizardfs-v.3.10.0/src/common/slice_read_planner.cc 2016-09-07 10:04:28.201447413 +0100
+@@ -16,6 +16,7 @@
+ along with LizardFS. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <cmath>
+ #include "common/platform.h"
+
+ #include "common/slice_read_planner.h"