summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Burrett2015-12-21 18:30:31 +0000
committerNick Burrett2015-12-21 18:31:13 +0000
commite21fe4720895cff217d4c372bfe491149a2d5e27 (patch)
tree5d553c4fe678f2cf00e67c54827dad3888849bce
downloadaur-e21fe4720895cff217d4c372bfe491149a2d5e27.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD56
-rw-r--r--cmake.patch7
-rw-r--r--lizardfs.install32
4 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bb84476ad10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 18:30:10 UTC 2015
+pkgbase = lizardfs
+ pkgver = 3.9.4
+ pkgrel = 1
+ url = http://lizardfs.com
+ install = lizardfs.install
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = asciidoc
+ depends = boost
+ depends = zlib
+ depends = fuse
+ depends = python2
+ depends = bash
+ depends = cmake
+ source = http://github.com/lizardfs/lizardfs/archive/v.3.9.4.tar.gz
+ source = cmake.patch
+ sha256sums = ece4e3f3433f6a26edf09b9f1ab0e867dd5e558f8966407792a38cb91ee91585
+ sha256sums = b233e631aed57fac8fc28003e390055582e45743e48c7ffe24af3a559b70e154
+
+pkgname = lizardfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..298b91e047ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Nick Burrett <nick@sqrt.co.uk>
+# lizardfs is a fork of moosefs and as such is a replacement for it.
+pkgname=lizardfs
+pkgver=3.9.4
+pkgrel=1
+pksdesc='High performing and fault tolerant distributed file system'
+url='http://lizardfs.com'
+conflics=('moosefs' 'mfs-master' 'mfs-chunkserver' 'mfs-client')
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('asciidoc' 'boost' 'zlib' 'fuse' 'python2' 'bash' 'cmake')
+install="$pkgname.install"
+source=("http://github.com/lizardfs/lizardfs/archive/v.${pkgver}.tar.gz"
+ "cmake.patch")
+sha256sums=('ece4e3f3433f6a26edf09b9f1ab0e867dd5e558f8966407792a38cb91ee91585'
+ 'b233e631aed57fac8fc28003e390055582e45743e48c7ffe24af3a559b70e154')
+
+prepare() {
+ cd "lizardfs-v.${pkgver%_*}"
+ patch -Np1 -i $srcdir/cmake.patch
+}
+
+
+build() {
+ cd "lizardfs-v.${pkgver%_*}"
+ ./configure
+ cd build-pack
+ make -j 2
+ #mkdir -p build
+ #cd build
+ #cmake \
+ # -DCMAKE_INSTALL_PREFIX=/usr \
+ # -DCMAKE_INSTALL_SBINDIR=/usr/bin \
+ # -DCMAKE_INSTALL_BINDIR=/usr/bin \
+ # -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ # -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
+ # -DCMAKE_INSTALL_INCLUDEDIR=/usr/include \
+ # -DCMAKE_INSTALL_DATAROOTDIR=/usr/share \
+ # -DCMAKE_INSTALL_LIBDIR=/usr/lib64 \
+ # -DCMAKE_BUILD_TYPE=Release ..
+ #make -j 2
+}
+
+package() {
+ make DESTDIR="$pkgdir" -C "lizardfs-v.${pkgver%_*}/build-pack" install
+ mkdir -p $pkgdir/usr/lib/systemd
+ for fn in lizardfs-cgiserv.service lizardfs-chunkserver.service \
+ lizardfs-master.service lizardfs-metalogger.service
+ do
+ install -m 0644 lizardfs-v.${pkgver%_*}/rpm/service-files/$fn $pkgdir/usr/lib/systemd/$fn
+ done
+ mv "$pkgdir"/usr/sbin/* "$pkgdir/usr/bin/"
+ rmdir "$pkgdir/usr/sbin"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..61ad508f4637
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,7 @@
+--- lizardfs-3.9.2/CheckIncludes.cmake.orig 2015-11-24 10:26:48.425365487 +0000
++++ lizardfs-3.9.2/CheckIncludes.cmake 2015-11-24 10:27:03.269328267 +0000
+@@ -1,3 +1,4 @@
++include(CheckIncludeFiles)
+ function(check_includes INCLUDES)
+ set(INCLUDE_MISSING FALSE)
+ foreach(INCLUDE_FILE ${INCLUDES})
diff --git a/lizardfs.install b/lizardfs.install
new file mode 100644
index 000000000000..740a3a9330ef
--- /dev/null
+++ b/lizardfs.install
@@ -0,0 +1,32 @@
+LFS_USER=mfs
+LFS_GROUP=mfs
+
+post_install() {
+ if ! getent passwd $LFS_USER &> /dev/null; then
+ useradd -u $LFS_UID -g $LFS_GROUP -m -s /bin/false $LFS_USER &> /dev/null
+ passwd -l $LFS_USER &> /dev/null
+ echo " ==> User '$LFS_USER' created"
+ fi
+ echo
+ echo 'For configuring LizardFS, the .cfg.dist files in /etc/mfs can'
+ echo 'be used as a basis for writing the corresponding .cfg files.'
+ echo
+ echo 'For troubleshooting a service, like "mfschunkserver", just running'
+ echo '"/usr/bin/mfschunkserver start" can be helpful.'
+ echo
+}
+
+post_remove() {
+ userdel $LFS_USER &> /dev/null
+ echo " ==> User '$LFS_USER' removed"
+}
+
+post_upgrade() {
+ echo
+ echo 'The latest release of MooseFS had several changes to how'
+ echo 'files are packaged and installed. There were also changes to'
+ echo 'the systemd service files. Please double-check that every'
+ echo 'service you wish to run is running as you intended.'
+ echo
+}
+