summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Petrescu2019-10-25 14:34:45 -0400
committerAdrian Petrescu2019-10-25 14:34:45 -0400
commitbc6b70e6664fdd5f6903d7c22283adfcba9906d5 (patch)
treec75201b773b06a3ff3c6ed6ddf540e036fb6bd8a
parentf4eecd1f738fa98e21a69346027d66d00cf3b4d7 (diff)
downloadaur-bc6b70e6664fdd5f6903d7c22283adfcba9906d5.tar.gz
Release v0.7.2
-rw-r--r--.SRCINFO17
-rw-r--r--0.7.2.patch36
-rw-r--r--PKGBUILD32
-rw-r--r--lizzie.sh6
4 files changed, 66 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f79425b741f4..c0fd1ff627c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lizzie
pkgdesc = Analysis interface for Leela Zero
- pkgver = 0.6
- pkgrel = 2
+ pkgver = 0.7.2
+ pkgrel = 1
url = https://github.com/featurecat/lizzie
arch = x86_64
license = GPLv3
@@ -11,14 +11,17 @@ pkgbase = lizzie
depends = bash
depends = java-runtime
depends = leela-zero
- source = https://github.com/featurecat/lizzie/archive/0.6.tar.gz
- source = winrate.patch::https://github.com/featurecat/lizzie/commit/d50f73a2cfb14b8f79c315f4057de8350bd5cfe5.patch
+ noextract = lznetwork.gz
+ source = https://github.com/featurecat/lizzie/archive/0.7.2.tar.gz
source = lizzie.sh
source = lizzie.desktop
- sha256sums = 0bc244914d80d7fecab1ef22e6ad2a540992019734e4081138bb9cf757bc79cd
- sha256sums = babc24f1bdd9e5c6315aff72eb6881489ec6ea0cae8bf277285a019c918dd665
- sha256sums = 58a4987ab4167aab557e1bcd2bb22daec252ce7c6397e76040c038516b74de70
+ source = 0.7.2.patch::https://github.com/featurecat/lizzie/commit/15f10dcfb0975ed350a74c6d79cc867e5f2e4a17.patch
+ source = lznetwork.gz::http://zero.sjeng.org/networks/0d2694c5f5c6657d4b39c829b0b5f6626c3f1e09fdaad791dcb7771207e9c9c3.gz
+ sha256sums = ffa468049b1d14585b2820e639e074ae8a2be6e8068d7cca9a84938c9b826a90
+ sha256sums = 100e1c567f150ad64f0925c84ce773c2afe0b6fc780a39e31bdf77c19adc2bed
sha256sums = cf5d1651023f04294e580243aa7ef05bc9ebedb468631f4035fd3d5ce0f212f0
+ sha256sums = 1f14871d3d8cdf85927fb778a5635dc60e30263be11a30e889f94c8337022348
+ sha256sums = a1cdb58a522d6a425445af071aae74df1073a67eecb8230a17eee47685d458ac
pkgname = lizzie
diff --git a/0.7.2.patch b/0.7.2.patch
new file mode 100644
index 000000000000..8b7c4eac2cb4
--- /dev/null
+++ b/0.7.2.patch
@@ -0,0 +1,36 @@
+From 15f10dcfb0975ed350a74c6d79cc867e5f2e4a17 Mon Sep 17 00:00:00 2001
+From: featurecat <annie.wagner.cs@gmail.com>
+Date: Fri, 25 Oct 2019 01:59:30 -0400
+Subject: [PATCH] update version number 0.7.2
+
+---
+ pom.xml | 2 +-
+ src/main/java/featurecat/lizzie/Lizzie.java | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pom.xml b/pom.xml
+index 45fb6736..f440fd5d 100644
+--- a/pom.xml
++++ b/pom.xml
+@@ -6,7 +6,7 @@
+
+ <groupId>featurecat</groupId>
+ <artifactId>lizzie</artifactId>
+- <version>0.7</version>
++ <version>0.7.2</version>
+
+ <properties>
+ <!-- Prevent warning: "[WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build is platform dependent!"-->
+diff --git a/src/main/java/featurecat/lizzie/Lizzie.java b/src/main/java/featurecat/lizzie/Lizzie.java
+index e235f310..1826d84a 100644
+--- a/src/main/java/featurecat/lizzie/Lizzie.java
++++ b/src/main/java/featurecat/lizzie/Lizzie.java
+@@ -20,7 +20,7 @@
+ public static GtpConsolePane gtpConsole;
+ public static Board board;
+ public static Leelaz leelaz;
+- public static String lizzieVersion = "0.7.1";
++ public static String lizzieVersion = "0.7.2";
+ private static String[] mainArgs;
+ public static EngineManager engineManager;
+
diff --git a/PKGBUILD b/PKGBUILD
index 3cff31b394ad..2231ab1015df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Adrian Petrescu <apetresc at gmail dot com>
-# Contributor: algebro <algebro at tuta dot io>
+# Maintainer: Adrian Petrescu <adrian@apetre.sc>
+# Contributor: algebro <algebro@tuta.io>
pkgname=lizzie
-pkgver=0.6
-pkgrel=2
+pkgver=0.7.2
+pkgrel=1
pkgdesc="Analysis interface for Leela Zero"
arch=('x86_64')
url="https://github.com/featurecat/lizzie"
@@ -11,22 +11,24 @@ license=('GPLv3')
depends=('bash' 'java-runtime' 'leela-zero')
makedepends=('git' 'maven' 'curl')
source=("https://github.com/featurecat/lizzie/archive/${pkgver}.tar.gz"
- 'winrate.patch::https://github.com/featurecat/lizzie/commit/d50f73a2cfb14b8f79c315f4057de8350bd5cfe5.patch'
'lizzie.sh'
- 'lizzie.desktop')
-sha256sums=('0bc244914d80d7fecab1ef22e6ad2a540992019734e4081138bb9cf757bc79cd'
- 'babc24f1bdd9e5c6315aff72eb6881489ec6ea0cae8bf277285a019c918dd665'
- '58a4987ab4167aab557e1bcd2bb22daec252ce7c6397e76040c038516b74de70'
- 'cf5d1651023f04294e580243aa7ef05bc9ebedb468631f4035fd3d5ce0f212f0')
-
+ 'lizzie.desktop'
+ '0.7.2.patch::https://github.com/featurecat/lizzie/commit/15f10dcfb0975ed350a74c6d79cc867e5f2e4a17.patch'
+ 'lznetwork.gz::http://zero.sjeng.org/networks/0d2694c5f5c6657d4b39c829b0b5f6626c3f1e09fdaad791dcb7771207e9c9c3.gz')
+noextract=('lznetwork.gz')
+sha256sums=('ffa468049b1d14585b2820e639e074ae8a2be6e8068d7cca9a84938c9b826a90'
+ '100e1c567f150ad64f0925c84ce773c2afe0b6fc780a39e31bdf77c19adc2bed'
+ 'cf5d1651023f04294e580243aa7ef05bc9ebedb468631f4035fd3d5ce0f212f0'
+ '1f14871d3d8cdf85927fb778a5635dc60e30263be11a30e889f94c8337022348'
+ 'a1cdb58a522d6a425445af071aae74df1073a67eecb8230a17eee47685d458ac')
prepare() {
cd $srcdir/$pkgname-$pkgver
# Use leela-zero-git's weights file instead of downloading a new one just for `mvn test`
ln -sf /usr/share/leela-zero/networks/weights.txt network.gz
- # Necessary bug fix to pass tests
- patch -Np1 -i "$srcdir/winrate.patch"
+ # Patch to apply post-release commit that bumps the version number to the right one
+ patch -Np1 -i "$srcdir/0.7.2.patch"
}
build() {
@@ -42,10 +44,8 @@ check() {
}
package() {
- sed -i 's/network.gz/\/usr\/share\/leela-zero\/networks\/weights.txt/g' "$pkgname"-"$pkgver"/config.txt
-
install -Dm644 "$pkgname-$pkgver"/target/lizzie-"$pkgver"-shaded.jar "$pkgdir"/usr/share/java/"$pkgname"/"$pkgname".jar
- install -Dm644 "$pkgname-$pkgver"/config.txt "$pkgdir"/usr/share/"$pkgname"/config.txt
install -Dm755 "$pkgname".sh "$pkgdir"/usr/bin/"$pkgname"
install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
+ install -Dm644 lznetwork.gz "$pkgdir"/usr/local/share/lizzie/lznetwork.gz
}
diff --git a/lizzie.sh b/lizzie.sh
index cafe41532a52..c3579dd23fb5 100644
--- a/lizzie.sh
+++ b/lizzie.sh
@@ -1,9 +1,11 @@
#!/bin/bash
if [ ! -d "$HOME/.local/share/lizzie" ]; then
mkdir -p "$HOME"/.local/share/lizzie
- cp /usr/share/lizzie/config.txt "$HOME"/.local/share/lizzie
if [ -f "$HOME/.local/share/leela-zero/leelaz_opencl_tuning" ]; then
ln -s "$HOME"/.local/share/leela-zero/leelaz_opencl_tuning "$HOME"/.local/share/lizzie/leelaz_opencl_tuning
fi
+ if [ -f /usr/local/share/lizzie/lznetwork.gz ]; then
+ ln -s /usr/local/share/lizzie/lznetwork.gz "$HOME"/.local/share/lizzie/lznetwork.gz
+ fi
fi
-cd "$HOME"/.local/share/lizzie && java -jar '/usr/share/java/lizzie/lizzie.jar' "$@" \ No newline at end of file
+cd "$HOME"/.local/share/lizzie && java -jar '/usr/share/java/lizzie/lizzie.jar' "$@"