summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Yip2023-05-13 08:49:19 -0500
committerJason Yip2023-05-13 08:49:19 -0500
commit038db6adf0bfbc7c0d321acfb9120d209509d503 (patch)
tree54e5f3e142a2a6872212dce371c8944c99b61450
downloadaur-038db6adf0bfbc7c0d321acfb9120d209509d503.tar.gz
[INIT]
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..feba5ab71e48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = llm-bin
+ pkgdesc = Run inference for Large Language Models on CPU, with Rust 🦀🚀🦙
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/rustformers/llm
+ arch = x86_64
+ license = MIT
+ license = APACHE
+ depends = glibc
+ depends = gcc-libs
+ source = llm-bin-0.1.1.tar.xz::https://github.com/rustformers/llm/releases/download/v0.1.1/llm-bin-cli-x86_64-unknown-linux-gnu.tar.xz
+ sha256sums = bc373197995c6a000fd5fe92a9286d88f0f8387f8cd6239f93f8921bfbeae8e7
+
+pkgname = llm-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a980af00afe5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fded7870a56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Porous3247 <pqtb3v7t at jasonyip1 dot anonaddy dot me>
+_pkgname="llm"
+pkgname="${_pkgname}-bin"
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Run inference for Large Language Models on CPU, with Rust 🦀🚀🦙'
+arch=('x86_64')
+url="https://github.com/rustformers/llm"
+license=('MIT' 'APACHE')
+depends=(glibc gcc-libs)
+_tarname="${_pkgname}-cli-${arch}-unknown-linux-gnu"
+source=("${_pkgname}-${pkgver}.tar.xz::${url}/releases/download/v${pkgver}/${_tarname}.tar.xz")
+sha256sums=('bc373197995c6a000fd5fe92a9286d88f0f8387f8cd6239f93f8921bfbeae8e7')
+
+package() {
+ cd "${srcdir}/${_tarname}"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${_pkgname}"
+}