summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuckyTurtleDev2023-05-14 11:37:25 +0200
committerLuckyTurtleDev2023-05-14 11:37:25 +0200
commitaaa869b5e2fad33ea7cf412aa8f5d4baf7025272 (patch)
tree2e32b9b0a95662ad80c6fe6617da0afc82c0975a
downloadaur-aaa869b5e2fad33ea7cf412aa8f5d4baf7025272.tar.gz
auto-update llm-cli 0.1.1
-rw-r--r--.SRCINFO16
-rw-r--r--.index.json5
-rw-r--r--PKGBUILD38
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bde0fbace218
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = llm-cli
+ pkgdesc = A CLI for running inference on supported Large Language Models. Powered by th...
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://crates.io/crates/llm-cli
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = Apache
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ source = llm-cli-0.1.1.tar.gz::https://crates.io/api/v1/crates/llm-cli/0.1.1/download
+ sha512sums = dd013d9b8f27001ed695a203b6f647e140c46bf6b7228b0c1b3d9b83abdff3e2f0060263e9cdd0ded967f7f13bdf568e1d2f2415b08679302911a894757e6a45
+
+pkgname = llm-cli \ No newline at end of file
diff --git a/.index.json b/.index.json
new file mode 100644
index 000000000000..3569bd7e7d44
--- /dev/null
+++ b/.index.json
@@ -0,0 +1,5 @@
+{
+ ".i": 1,
+ "crate": "llm-cli",
+ "version": "0.1.1"
+} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6060643266a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# -*- mode: Shell-script; eval: (setq indent-tabs-mode 't); eval: (setq tab-width 4) -*-
+# Maintainer: LuckyTurtleDev [aur at lukas1818 dot de]
+
+_crate="llm-cli"
+pkgname="llm-cli"
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='A CLI for running inference on supported Large Language Models. Powered by th...'
+url='https://crates.io/crates/llm-cli'
+license=('Apache' 'MIT')
+
+depends=('gcc-libs')
+makedepends=('cargo')
+
+source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/llm-cli/0.1.1/download")
+sha512sums=('dd013d9b8f27001ed695a203b6f647e140c46bf6b7228b0c1b3d9b83abdff3e2f0060263e9cdd0ded967f7f13bdf568e1d2f2415b08679302911a894757e6a45')
+
+# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
+arch=('aarch64' 'i686' 'x86_64')
+
+prepare() {
+ cd "$srcdir/$_crate-$pkgver"
+
+ cargo fetch --locked
+}
+
+build() {
+ cd "$srcdir/$_crate-$pkgver"
+ cargo build \
+ --offline \
+ --locked \
+ --release
+}
+
+package() {
+ cd "$srcdir/$_crate-$pkgver"
+ install -Dm755 "target/release/llm" -t "$pkgdir/usr/bin"
+} \ No newline at end of file