summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Yip2023-05-13 08:42:16 -0500
committerJason Yip2023-05-13 08:42:16 -0500
commit53f290dd43c0073a9b38084e6b0636fe06b5a41c (patch)
tree282d0f78d0669bba22302e1dda001bd1c947dc8f
parent5d1f25e4fc53640fdb5328ac6b61d2ec37ca76e7 (diff)
downloadaur-53f290dd43c0073a9b38084e6b0636fe06b5a41c.tar.gz
[FIX]: submodule should still be in sources
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83c3556f607c..61a952e74070 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = llm-git
pkgdesc = Run inference for Large Language Models on CPU, with Rust 🦀🚀🦙
pkgver = r515.774d4c0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/rustformers/llm
arch = any
license = MIT
@@ -14,6 +14,8 @@ pkgbase = llm-git
conflicts = llm
replaces = llama-cli
source = git+https://github.com/rustformers/llm
+ source = git+https://github.com/ggerganov/ggml
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = llm-git
diff --git a/PKGBUILD b/PKGBUILD
index 0b3e4c63aee6..e0f776d48f7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,20 @@
_pkgname="llm"
pkgname="${_pkgname}-git"
pkgver=r515.774d4c0
-pkgrel=2
-epoch=
+pkgrel=3
pkgdesc="Run inference for Large Language Models on CPU, with Rust 🦀🚀🦙"
arch=(any)
url="https://github.com/rustformers/${_pkgname}"
license=('MIT' 'APACHE')
-groups=()
depends=(glibc gcc-libs)
makedepends=(git cargo)
-checkdepends=()
-optdepends=()
provides=(llm)
conflicts=(llm)
replaces=(llama-cli)
-backup=()
-options=()
-install=
-changelog=
-source=("git+${url}")
-noextract=()
-sha256sums=('SKIP')
-validpgpkeys=()
+source=("git+${url}"
+ "git+https://github.com/ggerganov/ggml"
+ )
+sha256sums=('SKIP' 'SKIP')
prepare() {
@@ -48,5 +40,5 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
install -Dm755 target/release/llm -t "${pkgdir}/usr/bin/"
- install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${_pkgname}/"
}