summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Oteiza2015-06-08 22:54:08 -0400
committerMark Oteiza2015-06-08 22:54:08 -0400
commit2484e90539c4eb31a1dde9f79d3ced8ffe8d6198 (patch)
tree9c3169c8777004c2b62e227c942f04602414a824
downloadaur-2484e90539c4eb31a1dde9f79d3ced8ffe8d6198.tar.gz
initial commit
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD65
-rw-r--r--fix-libs.patch26
-rw-r--r--llpp.install11
4 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f00f8ce85cfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+# Generated by makepkg 4.2.1
+# Sun Apr 19 15:14:12 UTC 2015
+pkgbase = llpp-git
+ pkgdesc = Fast, featureful PDF viewer based on MuPDF.
+ pkgver = 21.r61.gdf146ab
+ pkgrel = 1
+ url = http://repo.or.cz/w/llpp.git
+ install = llpp.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = mupdf>=1.7
+ makedepends = ninja
+ makedepends = ocaml>=4.02
+ makedepends = ocaml-lablgl
+ depends = desktop-file-utils
+ depends = freetype2
+ depends = glu
+ depends = jbig2dec
+ depends = openjpeg2
+ depends = libgl
+ depends = libjpeg-turbo
+ depends = libx11
+ optdepends = xsel: Text selection
+ optdepends = file: llppac file type recognition
+ optdepends = gzip: llppac gzip archives
+ optdepends = xz: llppac xz archives
+ optdepends = bzip2: llpac bzip2 archives
+ optdepends = djvulibre: llppac djvu conversion
+ optdepends = ghostscript: llppac postscript, dvi, and djvu conversion
+ optdepends = princexml: llppac html conversion
+ optdepends = unoconv: llppac office document conversion
+ optdepends = librsvg: llppac svg conversion (preferred)
+ optdepends = inkscape: llppac svg conversion (alternative)
+ optdepends = imagemagick: llppac image conversion
+ provides = llpp
+ conflicts = llpp
+ source = git://repo.or.cz/llpp.git
+ source = fix-libs.patch
+ sha256sums = SKIP
+ sha256sums = fdda445e28d93ecdc0ad03b24da9a2b890a287e34c307c8762944edeacf1ae91
+
+pkgname = llpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fb74db323c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Contributor: holos
+# Contributor: Michael Witten <mfwitten>
+# Contributor: Vladimir Gorbunov <zaza>
+# Contributor: Earnest
+# Contributor: Attila Toth <menta>
+# Contributor: Flu
+
+pkgname=llpp-git
+pkgver=21.r61.gdf146ab
+pkgrel=1
+pkgdesc='Fast, featureful PDF viewer based on MuPDF.'
+arch=('i686' 'x86_64')
+url="http://repo.or.cz/w/llpp.git"
+license=('custom')
+provides=('llpp')
+conflicts=('llpp')
+install=llpp.install
+depends=('desktop-file-utils' 'freetype2' 'glu' 'jbig2dec' 'openjpeg2'
+ 'libgl' 'libjpeg-turbo' 'libx11')
+makedepends=('git' 'mupdf>=1.7' 'ninja' 'ocaml>=4.02' 'ocaml-lablgl')
+optdepends=(
+ 'xsel: Text selection'
+ 'file: llppac file type recognition'
+ 'gzip: llppac gzip archives'
+ 'xz: llppac xz archives'
+ 'bzip2: llpac bzip2 archives'
+ 'djvulibre: llppac djvu conversion'
+ 'ghostscript: llppac postscript, dvi, and djvu conversion'
+ 'princexml: llppac html conversion'
+ 'unoconv: llppac office document conversion'
+ 'librsvg: llppac svg conversion (preferred)'
+ 'inkscape: llppac svg conversion (alternative)'
+ 'imagemagick: llppac image conversion'
+)
+source=('git://repo.or.cz/llpp.git'
+ 'fix-libs.patch')
+sha256sums=('SKIP'
+ 'fdda445e28d93ecdc0ad03b24da9a2b890a287e34c307c8762944edeacf1ae91')
+
+pkgver() {
+ cd llpp
+ git describe --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+prepare() {
+ cd llpp
+ patch -p1 < ../fix-libs.patch
+}
+
+build() {
+ cd llpp
+ sh configure.sh -n .
+ ninja "$srcdir"/llpp/build/llpp.custom
+ make -C misc/completions
+}
+
+package() {
+ cd llpp
+ install -Dm755 build/llpp.custom "$pkgdir"/usr/bin/llpp
+ install -Dm755 misc/llppac "$pkgdir"/usr/bin/llppac
+ install -Dm755 misc/gc.py "$pkgdir"/usr/lib/llpp/gc
+ install -Dm644 misc/llpp.desktop "$pkgdir"/usr/share/applications/llpp.desktop
+ install -Dm644 README "$pkgdir"/usr/share/licenses/llpp/README
+ make -C misc/completions DESTDIR="$pkgdir" PREFIX=/usr install
+}
diff --git a/fix-libs.patch b/fix-libs.patch
new file mode 100644
index 000000000000..6c096ce34668
--- /dev/null
+++ b/fix-libs.patch
@@ -0,0 +1,26 @@
+diff --git a/build.ninja b/build.ninja
+index 3582131..da5e30a 100644
+--- a/build.ninja
++++ b/build.ninja
+@@ -1,7 +1,7 @@
+ cc = gcc
+ include .config
+ ocamlflags = -warn-error +a -w +a -g -safe-string
+-libs = -lmupdf $mujs -lpthread -Lmupdf/build/$buildtype
++libs = -lmupdf -lmujs -lpthread -Lmupdf/build/$buildtype
+
+ cflags = $cflags -Wall -Werror -Imupdf/include -g $
+ -std=c99 -pedantic-errors -Wunused-parameter -Wsign-compare -Wshadow
+diff --git a/configure.sh b/configure.sh
+index fa57c60..8ea2fad 100644
+--- a/configure.sh
++++ b/configure.sh
+@@ -45,7 +45,7 @@ expr >/dev/null "$0" : "/.*" && {
+ }
+ builddir=$(cd $builddir >/dev/null $builddir && pwd -P)
+
+-libs="$(pkg-config --libs $pkgs) -ljpeg -ljbig2dec -lopenjpeg"
++libs="$(pkg-config --libs $pkgs) -ljpeg -ljbig2dec -lopenjp2"
+
+ test $ocamlfind && {
+ lablgldir="$(ocamlfind query lablgl)" || exit 1
diff --git a/llpp.install b/llpp.install
new file mode 100644
index 000000000000..be8f4f9e1a13
--- /dev/null
+++ b/llpp.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ post_install
+}