summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-10-31 17:46:33 +0100
committerLW-archlinux2019-10-31 17:46:33 +0100
commit0dcfe17a63e05f1b4dcaba818ee0eaa998d08b7a (patch)
treec4ad5bb1a164102dddddb83851e48dc665fdbfc6
parentcb2de8d3a6feaa73d0f209fb98ce2984c5c86b2d (diff)
downloadaur-0dcfe17a63e05f1b4dcaba818ee0eaa998d08b7a.tar.gz
added staticlibs to options field
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD3
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cf1844afbc..b7171ed2729 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 10.0.0_r328055.120a5e9a745
+ pkgver = 10.0.0_r330761.aafe01fed4a
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = llvm-git
makedepends = python-recommonmark
makedepends = swig
makedepends = python
+ options = staticlibs
source = llvm-project::git+https://github.com/llvm/llvm-project.git
source = llvm-config.h
source = enable-SSP-and-PIE-by-default.patch
@@ -31,24 +32,24 @@ pkgbase = llvm-git
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=10.0.0_r328055.120a5e9a745-1
+ depends = llvm-libs-git=10.0.0_r330761.aafe01fed4a-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit (LLVM Integrated Tester)
optdepends = ocaml: for ocaml support
provides = aur-llvm-git
- provides = compiler-rt-git=10.0.0_r328055.120a5e9a745-1
- provides = clang-git=10.0.0_r328055.120a5e9a745-1
- provides = lld-git=10.0.0_r328055.120a5e9a745-1
- provides = lldb-git=10.0.0_r328055.120a5e9a745-1
- provides = polly-git=10.0.0_r328055.120a5e9a745-1
- provides = llvm-ocaml-git=10.0.0_r328055.120a5e9a745-1
- provides = compiler-rt=10.0.0_r328055.120a5e9a745-1
- provides = clang=10.0.0_r328055.120a5e9a745-1
- provides = lld=10.0.0_r328055.120a5e9a745-1
- provides = lldb=10.0.0_r328055.120a5e9a745-1
- provides = polly=10.0.0_r328055.120a5e9a745-1
- provides = llvm-ocaml=10.0.0_r328055.120a5e9a745-1
+ provides = compiler-rt-git=10.0.0_r330761.aafe01fed4a-1
+ provides = clang-git=10.0.0_r330761.aafe01fed4a-1
+ provides = lld-git=10.0.0_r330761.aafe01fed4a-1
+ provides = lldb-git=10.0.0_r330761.aafe01fed4a-1
+ provides = polly-git=10.0.0_r330761.aafe01fed4a-1
+ provides = llvm-ocaml-git=10.0.0_r330761.aafe01fed4a-1
+ provides = compiler-rt=10.0.0_r330761.aafe01fed4a-1
+ provides = clang=10.0.0_r330761.aafe01fed4a-1
+ provides = lld=10.0.0_r330761.aafe01fed4a-1
+ provides = lldb=10.0.0_r330761.aafe01fed4a-1
+ provides = polly=10.0.0_r330761.aafe01fed4a-1
+ provides = llvm-ocaml=10.0.0_r330761.aafe01fed4a-1
conflicts = llvm
conflicts = compiler-rt
conflicts = clang
@@ -66,6 +67,6 @@ pkgname = llvm-libs-git
depends = ncurses
depends = libxml2
provides = aur-llvm-libs-git
- provides = llvm-libs=10.0.0_r328055.120a5e9a745-1
+ provides = llvm-libs=10.0.0_r330761.aafe01fed4a-1
conflicts = llvm-libs
diff --git a/PKGBUILD b/PKGBUILD
index 22222145113..11a5c5582e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
pkgname=('llvm-git' 'llvm-libs-git')
-pkgver=10.0.0_r328055.120a5e9a745
+pkgver=10.0.0_r330761.aafe01fed4a
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -34,6 +34,7 @@ md5sums=('SKIP'
sha512sums=('SKIP'
'75e743dea28b280943b3cc7f8bbb871b57d110a7f2b9da2e6845c1c36bf170dd883fca54e463f5f49e0c3effe07fbd0db0f8cf5a12a2469d3f792af21a73fcdd'
'2fdbae0b62d33411beaf191920ff280f83fa80fd505a71077671027f27ed8c61c5867de3e6ee6f26734c7605037e86796404212182f8ffa71f4af6ed2c316a40')
+options=('staticlibs')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.