summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-02-16 20:54:43 +0100
committerLone_Wolf2021-02-16 20:54:43 +0100
commit30d98a91567322709007c8acdea1e4e1377ff221 (patch)
tree7992d620d36b8aaf116686b484fb0e87074278e5
parent03b5278d5225b888b70dcb98fb1883ca9772ebd2 (diff)
downloadaur-30d98a91567322709007c8acdea1e4e1377ff221.tar.gz
corrected llvm-libs-git so it conflicts with llvm-libs again
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c218a2972d40..46461091b9b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 12.0.0_r377736.98a8344895a8
+ pkgver = 13.0.0_r380093.f350fe8c55a6
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -37,7 +37,7 @@ pkgbase = llvm-git
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=12.0.0_r377736.98a8344895a8-1
+ depends = llvm-libs-git=13.0.0_r380093.f350fe8c55a6-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit = LLVM Integrated Tester
@@ -69,13 +69,13 @@ pkgname = llvm-libs-git
depends = libxml2
depends = z3
depends = lua
- optdepends = llvm-libs: for LLVMgold linker
provides = aur-llvm-libs-git
provides = llvm-libs
+ conflicts = llvm-libs
pkgname = llvm-ocaml-git
pkgdesc = OCaml bindings for LLVM
- depends = llvm-git=12.0.0_r377736.98a8344895a8-1
+ depends = llvm-git=13.0.0_r380093.f350fe8c55a6-1
depends = ocaml
depends = ocaml-ctypes
provides = llvm-ocaml
diff --git a/PKGBUILD b/PKGBUILD
index 35f97eccbda6..80678617ae74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgname=('llvm-git' 'llvm-libs-git' 'llvm-ocaml-git')
-pkgver=12.0.0_r377736.98a8344895a8
+pkgver=13.0.0_r380093.f350fe8c55a6
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -106,7 +106,6 @@ package_llvm-git() {
optdepends=('python: for scripts'
'python-setuptools: for using lit = LLVM Integrated Tester'
)
- # yes, I know polly is not in official repos. It just feels cleaner to list it
provides=(aur-llvm-git compiler-rt-git clang-git lldb-git lld-git polly-git
compiler-rt clang lldb polly lld )
# A package always provides itself, so there's no need to provide llvm-git
@@ -165,14 +164,19 @@ package_llvm-libs-git() {
pkgdesc="runtime libraries for llvm-git"
depends=('gcc-libs' 'zlib' 'libffi' 'libedit' 'ncurses' 'libxml2' 'z3' 'lua')
provides=(aur-llvm-libs-git llvm-libs)
- optdepends=('llvm-libs: for LLVMgold linker')
-
+ conflicts=('llvm-libs')
install -d "$pkgdir"/usr/lib
cp -P \
"$srcdir"/lib{LLVM,LTO,Remarks}*.so* \
+ "$srcdir"/LLVMgold.so \
"$pkgdir"/usr/lib/
+ # Symlink LLVMgold.so from /usr/lib/bfd-plugins
+ # https://bugs.archlinux.org/task/28479
+ install -d "$pkgdir"/usr/lib/bfd-plugins
+ ln -s ../LLVMgold.so "$pkgdir"/usr/lib/bfd-plugins/LLVMgold.so
+
cd llvm-project/
install -Dm644 llvm/LICENSE.TXT "$pkgdir"/usr/share/licenses/$pkgname/llvm-LICENSE
install -Dm644 clang/LICENSE.TXT "$pkgdir"/usr/share/licenses/$pkgname/clang-LICENSE