summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-04-14 15:30:48 +0200
committerLW-archlinux2019-04-14 15:30:48 +0200
commit4b87e17dacfeb031d4c457b6b7032706662910fd (patch)
tree329b06054814c5ebe39ed9acb8fa6dd1f39ce877
parent5412daa4f0670937fa5ca1b756f31415a3a74093 (diff)
downloadaur-4b87e17dacfeb031d4c457b6b7032706662910fd.tar.gz
remove unneeded parts of sourcetree
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 961e94a960b0..1096071824db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = llvm-git
- pkgver = 9.0.0_r314109.3dc7c7ca311
- pkgrel = 2
+ pkgver = 9.0.0_r314159.065480daf2e
+ pkgrel = 1
url = https://llvm.org/
arch = x86_64
license = custom:University of Illinois/NCSA Open Source License
diff --git a/PKGBUILD b/PKGBUILD
index d47e2343e4fc..03c686bb53c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,8 @@
pkgname=('llvm-git' 'llvm-libs-git')
-pkgver=9.0.0_r314109.3dc7c7ca311
-pkgrel=2
+pkgver=9.0.0_r314159.065480daf2e
+pkgrel=1
_ocaml_ver=4.07.1
arch=('x86_64')
url="https://llvm.org/"
@@ -27,8 +27,8 @@ makedepends=( 'git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2' 'py
options=('staticlibs')
source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
- llvm-config.h
- enable-SSP-and-PIE-by-default.patch)
+ 'llvm-config.h'
+ 'enable-SSP-and-PIE-by-default.patch')
sha256sums=('SKIP'
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48'
'58f86da25eb230ed6d423b5b61870cbf3bef88f38103ca676a2c7f34b2372171')
@@ -62,6 +62,11 @@ prepare() {
pushd clang
patch -Np1 -i "$srcdir"/enable-SSP-and-PIE-by-default.patch
popd
+ # llvm-project contains a lot of stuff, remove parts that aren't used by this package
+ rm -rf debuginfo-tests libclc libcxx libcxxabi libunwind llgo openmp parallel-libs pstl
+
+ # llvm cmake uses things automagickally when they're at certain places in the sourcetree
+ # TODO try building as external projects to avoid moving sourcetree around
mv clang llvm/tools/clang
mv clang-tools-extra llvm/tools/clang/tools/extra
mv compiler-rt llvm/projects/compiler-rt
@@ -94,7 +99,7 @@ build() {
-DLLVM_VERSION_SUFFIX="" \
-DPOLLY_ENABLE_GPGPU_CODEGEN=ON \
-DLINK_POLLY_INTO_TOOLS=ON
- ninja all ocaml_doc
+ ninja "$MAKEFLAGS" all ocaml_doc
}
check() {